PAT A 1106. Lowest Price in Supply Chain (25)

原文链接: PAT A 1106. Lowest Price in Supply Chain (25)

上一篇: 1094. The Largest Generation (25)

下一篇: PAT A1004. Counting Leaves (30)

1106. Lowest Price in Supply Chain (25)

https://www.patest.cn/contests/pat-a-practise/1106

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

题目大意:提供一棵树,在树根处货物的价格为p,从根结点开始每往下一层,该层货物价格将会在父亲结点的价格上增加r%。求叶子结点出能获得的最低价格以及能提供最低价格的叶子结点数
分析:dfs。保存深度的最小值mindepth,以及最小值下该深度的个数minnum。深度优先搜索参数为index和depth,不断遍历index结点的孩子结点,直到当前结点没有孩子结点为止return~~~~

深度如果比最小深度大,可以直接返回

#include <iostream>
#include <cstdio>
#include <vector>
#include <cmath>
using namespace std;

vector< vector<int> > tree;
int n;		//数目,价格,比率 
double p, r;
int minDepth = 1<<20, minCount = 0;		//最小叶的深度和对应的数目

void dfs(int root, int depth) {
	if(depth>minDepth)
		return; 
	
	//叶节点 
	if (tree[root].empty()) {
		if (minDepth > depth) {
			minDepth = depth;
			minCount = 1;
		} else if (minDepth == depth) {
			minCount++;
		}
	}
	for (int i = 0; i < tree[root].size(); i++)
		dfs(tree[root][i], depth + 1);
}

int main(int argc, char *argv[]) {
	scanf("%d %lf %lf", &n, &p, &r);
	r /= 100;
	tree.resize(n);
	for (int i = 0; i < n; i++) {
		int cnt, t;
		scanf("%d", &cnt);
		for (int j = 0; j < cnt; j++) {
			scanf("%d", &t);		//t是i的孩子 
			tree[i].push_back(t);
		}
	}
	//根节点0在第0层 
	dfs(0, 0);
	printf("%.4lf %d\n", p*pow(1 + r, minDepth), minCount);
	return 0;
}

BFS

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;
vector< vector<int> > tree;
vector<int> level; 		//level[i] 表示i节点在第几层 
int main(int argc, char *argv[]) {
	int n;
	double p, r;
	scanf("%d%lf%lf", &n, &p, &r);
	r /= 100;
	tree.resize(n);
	level.resize(n);
	for (int i = 0; i < n; i++) {
		int k, t;
		scanf("%d", &k);
		for (int j = 0; j < k; j++) {
			scanf("%d", &t);
			tree[i].push_back(t);
		}
	}

	queue<int> q;
	q.push(0);
	level[0] = 0;		//根节点在第0层 
	int minLevel = 1 << 20, minCount = 0;
	while (!q.empty()) {
		int top = q.front();
		q.pop();
		if (tree[top].empty()) {
			if (minLevel > level[top]) {
				minLevel = level[top];
				minCount = 1;
			} else if (minLevel == level[top]) {
				minCount++;
			} else {
				//层数过多跳过 
				continue;
			}
		}

		for (int i = 0; i < tree[top].size(); i++) {
			level[tree[top][i]] = level[top] + 1;
			q.push(tree[top][i]);
		}
	}

	printf("%.4lf %d\n", p*pow(1 + r, minLevel), minCount);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值