PAT A1015. Reversible Primes (20)

原文链接: PAT A1015. Reversible Primes (20)

上一篇: PAT B1034. 有理数四则运算(20)

下一篇: PAT A1078. Hashing (25)

1015. Reversible Primes (20)

https://www.patest.cn/contests/pat-a-practise/1015

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

int isPrime(int n) {
	if (n < 3)
		return n > 1;

	int sqr = sqrt(1.0*n);
	for (int i = 2; i <= sqr; i++)
		if (n%i == 0)
			return 0;
	return 1;
}
//存放数字位数 
int d[111];
int main(int argc, char *argv[]) {
	int n, radix;
	while (scanf("%d", &n) != EOF && n >= 0) {
		scanf("%d", &radix);
		if (!isPrime(n))
			printf("No\n");
		else {
			int len = 0;
			do {
				d[len++] = n%radix;
				n /= radix;
			} while (n);
			for (int i = 0; i < len; i++)
				n = n*radix + d[i];
			if (isPrime(n))
				printf("Yes\n");
			else
				printf("No\n");
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值