1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 78607 Accepted: 17589

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2Case 2: 1


题意; 大意是在坐标平面的海岸面有n个岛屿,有半径为 d 的雷达,要求能覆盖所以岛屿的最少雷达数量,不能全部覆盖就输出-1

思路:区间贪心,取当前区间的后端点为 themin,如果后一个区间的前端点小于 themin ,则可以公用一个雷达,直接跳过

                                                                                如果后一个区间的后端点小于  themin,说明前一个区间包含后一个区间

                                                                                如果后一个区间的前端点大于 themin ,则需要更改当前区间为 themin,雷达数量加 1,(主要以这条为贪心标准)

注意:数据类型为 double ,scanf printf 输入输出,不然可能超时

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
double d;
int n;
int thecase = 1;
bool isover;
struct Section{ //区间 
	double low,high;
};
struct Island{//岛屿坐标 
	double x,y;
};
int compare(Section a,Section b)//sort结构体排序比较函数 
{
	if(a.low!=b.low)
		return a.low < b.low;
	else
		return a.high < b.high;
}
Island island[1001];
Section section[1001];
int main()
{
	while(~scanf("%d%lf",&n,&d)&&n!=0&&d!=0)
	{

		isover = false;//如果有 > d 的点说明无法覆盖,直接输出 -1; 
		for(int i=0;i<n;i++)
		{
			cin>>island[i].x>>island[i].y;
			if(island[i].y>d) isover = true;
		}
		if(isover)
		{
			printf("Case %d: -1\n",thecase++);continue;		
		}

		for(int i=0;i<n;i++)//求区间,注意用double 
		{
			double temp = sqrt(d*d-island[i].y*island[i].y);
			section[i].low = island[i].x - temp;
			section[i].high = island[i].x + temp;
		}
		sort(section,section+n,compare);//STL排序函数,不懂百度 
		int count = 1;
		double themin = section[0].high;//贪心 
		for(int i=1;i<n;i++)
		{
			if(section[i].low>themin)
			{
				count++;
				themin = section[i].high;
			}else if(section[i].high<themin)
			{
				themin = section[i].high;
			}
		}
		printf("Case %d: %d\n",thecase++,count);
	}
	return 0;
} 
奈何我冒泡的算法如何打动你超时的心!!!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值