1006. Sign In and Sign Out (25)

1006. Sign In and Sign Out (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133


题意:每天都有人去机房登记,第一个去的人负责开门,最后一个走的负责关门,给你M个人员的登记时间和离开时间,求出开门的人和关门的人的ID

思路:找到sign_in的最小值和sign_out的最大值所在的位置,输出对应的ID就好,简单的时间判断

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

const int MAXM = 1024;
int M;


struct Records {
	int h1,h2, m1,m2, s1,s2;
	char ID[20];
} R[MAXM];

bool cmp1(int a,int b) //时间 a 是否比时间 b 小
{
	if (R[a].h1 != R[b].h1)
		return R[a].h1 < R[b].h1;
	if (R[a].m1 != R[b].m1)
		return R[a].m1 < R[b].m1;
	return R[a].s1 < R[b].s1;
}
bool cmp2(int a, int b)//时间 a 是否比时间 b 大
{
	if (R[a].h2 != R[b].h2)
		return R[a].h2 > R[b].h2;
	if (R[a].m2 != R[b].m2)
		return R[a].m2 > R[b].m2;
	return R[a].s2 > R[b].s2;
}

int main()
{
	scanf("%d", &M);
	int p1 = 0, p2 = 0;//最早时间所在位置,最晚时间所在位置
	for (int i = 0; i < M; i++)
	{
		scanf("%s %d:%d:%d %d:%d:%d", &R[i].ID, &R[i].h1, &R[i].m1, &R[i].s1, &R[i].h2, &R[i].m2, &R[i].s2);
		if (cmp1(i,p1) == true)
		{
			p1 = i;
		}
		if (cmp2(i,p2) == true)
		{
			p2 = i;
		}
	}
	printf("%s %s\n", R[p1].ID, R[p2].ID);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值