CA Loves Stick

http://acm.hdu.edu.cn/showproblem.php?pid=5655

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2118 Accepted Submission(s): 609

Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)

Input
First line contains T denoting the number of testcases.
T testcases follow. Each testcase contains four integers a,b,c,d in a line, denoting the length of sticks.
1≤T≤1000, 0≤a,b,c,d≤2^63−1

Output
For each testcase, if these sticks can spell a quadrilateral, output “Yes”; otherwise, output “No” (without the quotation marks).

Sample Input
2
1 1 1 1
1 1 9 2

Sample Output
Yes
No

Source
BestCoder Round #78 (div.2)

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int T,i;
    long int a[4];
    scanf("%d",&T);
    while(T--)
    {
        int sum=0;
        for(i=0;i<4;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sort(a,a+4);
        if(a[3]<sum-a[3])
            printf("Yes\n");
        else
            printf("No\n");
    }
}

未考虑到可能会有数字为零。

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int T,i;
    long long a[4];
    scanf("%d",&T);
    while(T--)
    {
        int sum=0;
        for(i=0;i<4;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
         sort(a,a+4);
        if(a[3]>=(sum-a[3])||a[0]==0)
            printf("No\n");
        else
            printf("Yes\n");

    }
}

由于a[i]是很大的,所以用long long ,%I64d或者%lld。

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int T,i;
    long long a[4];
    scanf("%d",&T);
    while(T--)
    {
        for(i=0;i<4;i++)
        scanf("%I64d",&a[i]);
         sort(a,a+4);
        if(a[3]>=(a[0]+a[1]+a[2])||a[0]==0)
            printf("No\n");
        else
            printf("Yes\n");

    }
}

相比上下两个代码,不同的是范围,a[3]>=(a[0]+a[1]+a[2])和a[0]<=(a[3]-a[1]-a[2]),前面一个的可能会超出范围。

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    long long a[4];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d%I64d%I64d%I64d",&a[0],&a[1],&a[2],&a[3]);
         sort(a,a+4);
        if(a[0]<=(a[3]-a[1]-a[2])||a[0]==0)
            printf("No\n");
        else
            printf("Yes\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值