HDoj.5655 CA Loves Stick【基础】 2016/04/04

CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 636    Accepted Submission(s): 224


Problem Description
CA loves to play with sticks.
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input
First line contains T denoting the number of testcases.
T testcases follow. Each testcase contains four integers a,b,c,d in a line, denoting the length of sticks.
1T1000, 0a,b,c,d2631
 

Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
 

Sample Input
  
  
2 1 1 1 1 1 1 9 2
 

Sample Output
  
  
Yes No
 

Source

四边形:最长边小于其余三边之和。
#include<iostream>
#include<cstdio>
#include<cstring>
#define LL __int64

using namespace std;

int main(){
    LL a,b,c,d;
    int t;
    scanf("%d",&t);
    while( t-- ){
        scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&d);
        if( !a || !b || !c || !d ){
            printf("No\n");
            continue;
        }
        LL t;
        if( a < b ){
            t = a;
            a = b;
            b = t;
        }
        if( a < c ){
            t = a;
            a = c;
            c = t;
        }
        if( a < d ){
            t = a;
            a = d;
            d = t;
        }
        if( d>a-b-c )
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值