LightOJ 1189 - Sum of Factorials(贪心+阶乘)

Description

Given an integer n, you have to find whether it can be expressed as summation of factorials. For given n, you have to report a solution such that

n = x1! + x2! + ... + xn! (xi < xj for all i < j)

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1018).

Output

For each case, print the case number and the solution in summation of factorial form. If there is no solution then print 'impossible'. There can be multiple solutions, any valid one will do. See the samples for exact formatting.

Sample Input

4

7

7

9

11

Sample Output

Case 1: 1!+3!

Case 2: 0!+3!

Case 3: 1!+2!+3!

Case 4: impossible

 

 

 

                                                                                           

这一题题意就是给你一个数,问哪些数的阶乘等于这个数,并按照样例从小到大输出这些数的每一项,其中每一项只可以用一次,如果不存在这些数,就输出impossible。

贪心的题型,每次考虑最大的放入里面,从后往前找。

 

#include<cstdio>
long long p[21]={1,1,2,6,24,120,720,5040,40320,362880,3628800,39916800,479001600,6227020800,87178291200,1307674368000,20922789888000,355687428096000,6402373705728000,121645100408832000,2432902008176640000};
int main()
{
	int t,cas=1;
	scanf("%d",&t);
	while(t--)
	{
		int a[20],flag=0; 
		long long  n;
		scanf("%lld",&n);			
	   	for(int i=20;i>=0;i--)	    	
		{
			if(n>=p[i])
			{
				n=n-p[i];
				a[flag++]=i;				
			}					    
		}
		printf("Case %d: ",cas++);
		if(n==0)
		{
			for(int i=flag-1;i>=0;i--)
			{
				if(i==flag-1)
				  printf("%d!",a[i]);
				else printf("+%d!",a[i]);
			}
			printf("\n");
		}
		else 
		printf("impossible\n");
	 } 
	 return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值