HDU-4475 Downward paths(找规律)

Downward paths

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 844    Accepted Submission(s): 282


Problem Description
================
  Hi! I am an ACMer from CSU. This contest made by me is to celebrate my girlfriend’s birthday although the problems in this contest do not relate to her in fact. :) Any way, happy birthday to you, honey!
  Thanks to LCY, I have this chance to share my ideas and works with you. Good luck and have fun!
================
  We have a graph with size = N like that in Figure 1. Then we are going to find a downward path from the top node to one bottom node.
  First, we select the top node as the beginning. Then at any node, we can go horizontally or downward along the blue edge and reach the next node. The finding will be end when we reach one of the bottom nodes. After that we can get a downward path from the top node to one bottom node. Note that we can not pass a blue edge that we have passed ago during each finding.
  Your task is to calculate there exists how many downward paths.
 

Input
  There is an integer T (1 <= T <= 1000) in the first line, which indicates there are T test cases in total.
  For each test case, there is only one integer N (1 <= N <= 10^18) indicates the size of the graph.
 

Output
  For each test case, you should output the correct answer of the above task in one line.
  Because the answer may be very large, you should just output the remainder of it divided by 1000003.
 

Sample Input
  
  
2 1 2
 

Sample Output
  
  
2 8
Hint
  For Sample 2, the yellow paths in Figure 2 show the 8 downward paths.
 
********************************************************************************************
题意:从顶点走到底有多少条路可以走
解题思路:
    size = 1时:2*(1+0) = 2
size = 2时:2*(1+1) *2(1+0)= 8
size = 3时:2*(1+1)*2*(1+2)*2*(1+0)=48
除了最上面的顶点和最下面的点以外,size大于1时,
1
 |  |
2 ————3
 |  |
4————5————6
| | | |
7————8————9————10
例如2号点可以有去4,5号点2条路,而且同时4, 5, 6这一层有2个边,4-5和5-6;
所以2号点到下一层就有2*(1+2)条路。

所以当size=n时,2 *(1+1)* 2 *(1+2)* 2 *(1+3) * ~~~ * 2 *(1+n-1)* 2 *(1+0)= 2^n * n!。

当大于1000003之后,全部n%1000003=0。

*********************************************************************************************
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <sstream>
#include <algorithm>
using namespace std;
#define pb push_back
#define mp make_pair
#define mset(a, b)  memset((a), (b), sizeof(a))
typedef long long LL;
const int inf = 0x3f3f3f3f;
const int maxn = 1000000+10;
const int mod = 1000003;
LL a[maxn];
int main()
{
    a[0] = 1;
    for(int i=1;i<=maxn;i++)
        a[i] = (a[i-1] * i * 2)%mod;
    LL T;
    cin  >> T;
    while(T--){
        LL n;
        cin >> n;
        if(n >= mod ){
            cout << "0" << endl;
            continue;
        }
        cout << a[n] << endl;
    }
    return 0;
}


*********************************************************************************************

*********************************************************************************************
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值