PAT——1041 Be Unique

1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
#include <cstdio>
#include <vector>
#include <cmath>
#include <map>
using namespace std;

int main(){

    int n;
    while(scanf("%d",&n)!=EOF){
        vector<int> vi;
        map<int,int> mp;
        for(int i=0;i<n;++i){
            int tmp;
            scanf("%d",&tmp);
            if(tmp>=1&&tmp<=pow(10,5)){
                vi.push_back(tmp);

                if(mp.find(tmp)==mp.end()){
                    mp[tmp]=0;
                }else{
                    mp[tmp]++;
                }
            }
        }
        int i;
        for(i=0;i<n;++i){
            int key=vi[i];
            if(mp[key]==0){
                printf("%d\n",key);
                break;
            }
        }
        if(i==n)    printf("None\n");
        mp.clear();
        vi.clear();

        /*
        vector <int> vi;
        for(int i=0;i<n;++i){
            int  tmp;
            scanf("%d",&tmp);
            if(tmp>=1&&tmp<=pow(10,5))   vi.push_back(tmp);
        }
        bool bigFlag=false;//判断有没有出现唯一数
        for(int i=0;i<n-1;++i){
            bool flag=false;    //vi[i]是唯一
            for(int j=i+1;j<n;j++){
                if(vi[i]==vi[j]) {
                    vi[j]=0;
                    flag=true;
                }
            }
            if(flag)    vi[i]=0; //不是唯一
            else{//是唯一
                printf("%d\n",vi[i]);
                bigFlag=true;
                break;
            }
        }//for
        if(!bigFlag) printf("None\n");  //整个数组没有唯一的
        vi.clear();
        */

    }
    return 0;
}

总结:一开始以为去重嘛,现成的set就可以用嘛,后来发现事情并没有那么简单......纯用vector我觉得可以的,但是PAT没通过。。。还得继续改bug,,,后面用来vector和map比较简单,vector保证输入的顺序,map记录每个数的出现次数,确定唯一性。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值