第七题 UVa1593 代码对齐 Alignment of Code

116 篇文章 1 订阅
27 篇文章 0 订阅

PDF
You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which
is basically a text editor with bells and whistles. You are working on a module that takes a piece of
code containing some definitions or other tabular information and aligns each column on a fixed vertical
position, while keeping the resulting code as short as possible, making sure that only whitespaces that
are absolutely required stay in the code. So, that the first words on each line are printed at position
p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first
words end at or before position p2 − 2; the third words on each line are printed at the minimal possible
position p3, such that all second words end at or before position p3 − 2, etc.
For the purpose of this problem, the code consists of multiple lines. Each line consists of one or
more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all
ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to
126 inclusive). Whitespace consists of space characters (ASCII code 32).
Input
The input file contains one or more lines of the code up to the end of file. All lines (including the last
one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word,
each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of
the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters
long. There are at most 1000 lines in the input file.
Output
Write to the output file the reformatted, aligned code that consists of the same number of lines, with
the same words in the same order, without trailing and leading spaces, separated by one or more spaces
such that i-th word on each line starts at the same position pi
.
Note for the Sample:
The ‘⊔’ character in the example below denotes a space character in the actual files (ASCII code
32).
Sample Input
␣␣start:␣␣integer;␣␣␣␣//␣begins␣here
stop:␣integer;␣//␣␣ends␣here
␣s:␣␣string;
c:␣␣␣char;␣//␣temp
Sample Output
start:␣integer;␣//␣begins␣here
stop:␣␣integer;␣//␣ends␣␣␣here
s:␣␣␣␣␣string;
c:␣␣␣␣␣char;␣␣␣␣//␣temp

#include<cstring>
#include<cstdio>
#include<iostream>
#include<vector>
#include<sstream>
#include<string>
#define Maxn 1002
using namespace std;

vector<string> txt[Maxn];
string line,s;
int length[Maxn];

inline void Print(string cs,int widee) {
	cout << cs;
	for(int i=1;i<=widee-cs.size();i++) cout<<' ';
	cout << ' ';
	
}


int main() {
	int r=0,c=0;// r - 行   c - 列 
	while(getline(cin,line)) {
		stringstream ccin(line);
		r++; c = 0;
		while(ccin>>s) {
			txt[r].push_back(s);
			c++;
			length[c] = max(length[c],(int)s.size());
		}
	}
	for(int i=1;i<=r;i++) {
		for(int j=0;j<txt[i].size()-1;j++) 
			Print(txt[i][j],length[j+1]);// 列是从1 开始记录的  但是 vector从0开始push_back 
		cout<<txt[i][txt[i].size()-1]<<endl;///UVa 卡格式卡的严   行末空格不行 
	}
	return 0;
} 

/*
简记C++ string流输入输出
stringstream line(ss) (ss 也是一个字符串类型)
一次性读完这一行
假设 ss="abcd ddasa" 
接下来  line>>s; line >> s1;
则 s="abcd" s1= "ddasa" 
C++  STL处理真的很方便    就是速度处理 有点慢 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值