第十一题 UVA10763 交换学生 Foreign Exchange

116 篇文章 1 订阅

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has
sky-rocketed and now you need assistance with your task.
The program your organization runs works as follows: All candidates are asked for their original
location and the location they would like to go to. The program works out only if every student has a
suitable exchange partner. In other words, if a student wants to go from A to B, there must be another
student who wants to go from B to A. This was an easy task when there were only about 50 candidates,
however now there are up to 500000 candidates!
Input
The input file contains multiple cases. Each test case will consist of a line containing n – the number
of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each
candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s original location and the candidate’s target location respectively. Locations will be represented
by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program.
The input is terminated by a case where n = 0; this case should not be processed.
Output
For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out,
otherwise print ‘NO’.
Sample Input
10
1 2
2 1
3 4
4 3
100 200
200 100
57 2
2 57
1 2
2 1
10
1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
0
Sample Output
YES
NO

/*
昨天刚刚复习了set  一看这题 set 插 pair
 写了半天  写了个差不多, 然后发现pair无法排序,需要重载运算符
 后来又想map啥的  。。。。
 最后两遍sort    gg

*/ 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define Maxn 500005
using namespace std;
int a[Maxn],b[Maxn];
int main( ){
	int n;
	while(scanf("%d",&n) == 1 && n) {
		for(int i=1; i<=n; i++) scanf("%d %d",&a[i],&b[i]);
		sort(a + 1 , a + n + 1);
		sort(b + 1 , b + n + 1);
		bool flag = true;
		for(int i=1; i<=n; i++) 
			if(a[i] != b[i]) {
				flag = false;
				break;
			}
		flag  ? printf("YES\n") : printf("NO\n");
	}
	
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值