第十四题 UVA11988 破损的键盘 Broken Keyboard (a.k.a. Beiju Text)

116 篇文章 1 订阅

PDF

终于看到数据结构了…第一篇 链表

恩 链表是个好东西

You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem
with the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed
(internally).
You’re not aware of this issue, since you’re focusing on the text and did not even turn on the
monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor).
In Chinese, we can call it Beiju. Your task is to find the Beiju text.
Input
There are several test cases. Each test case is a single line containing at least one and at most 100,000
letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed
internally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file
(EOF).
Output
For each case, print the Beiju text on the screen.
Sample Input
This_is_a_[Beiju]_text
[[]][][]Happy_Birthday_to_Tsinghua_University
Sample Output
BeijuThis_is_a__text
Happy_Birthday_to_Tsinghua_University

//书上看到链表了, 上学的时候链表就没学好,这回都得补上 gg

#include<cstring>
#include<cstdio>
#include<iostream>
#define Maxn 120005
using namespace std;
int Nxt[Maxn],cur,last;
char s[Maxn];
//cur 不代表遍历到的位置 而是遍历到的i位应该输出到cur的右侧
//last 记录最靠右的位置, 以便cur随时可以"回来" 
int main(int argc,char *argv[]) {
	while(scanf("%s", s + 1) == 1) {
		int len = strlen (s + 1);
		cur = last = 0;
		Nxt[0] = 0;
		for(int i=1; i<=len; i++) {
			char ch = s[i];
			if(ch == '[') cur = 0;
			else if(ch == ']') cur = last;
			else {
				Nxt[i] = Nxt[cur];
				Nxt[cur] = i;
				if(cur == last) last = i;
				cur = i;
			}
		}
		for(int i=Nxt[0]; i!=0; i=Nxt[i]) 
			printf("%c",s[i]);
		printf("\n");
	} 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值