第七十一题 UVA1262 密码 Password

116 篇文章 1 订阅
75 篇文章 0 订阅

Shoulder-surfing is the behavior of intentionally and stealthily watching the screen of another person’s
electronic device, such as laptop computer or mobile phone. Since mobile devices prevail, it is getting
serious to steal personal information by shoulder-surfing.
Suppose that we have a smart phone. If we touch the screen keyboard directly to enter the password,
this is very vulnerable since a shoulder-surfer easily knows what we have typed. So it is desirable to
conceal the input information to discourage shoulder-surfers around us. Let me explain one way to do
this.
You are given a 6 × 5 grid. Each column can be considered the visible part of a wheel. So you can
easily rotate each column wheel independently to make password characters visible. In this problem,
we assume that each wheel contains the 26 upper letters of English alphabet.
See the following Figure 1.

See the following Figure 1.
Figure 1. 6 × 5 window clips a valid grid representation for a password.
Assume that we have a length-5 password such as p1 p2 p3 p4 p5. In order to pass the authentication
procedure, we should construct a configuration of grid space where each pi appears in the i-th column
of the grid. In that situation we say that the user password is accepted.
Figure 2. A valid grid
representation for password
‘COMPU’.
Let me start with one example. Suppose that our password was
set ‘COMPU’. If we construct the grid as shown in Figure 2 on next
page, then the authentication is successfully processed.
In this password system, the position of each password character in each column is meaningless. If each of the 5 characters in
p1 p2 p3 p4 p5 appears in the corresponding column, that can be
considered the correct password. So there are many grid configurations allowing one password. Note that the sequence of letters
on each wheel is randomly determined for each trial and for each
column. In practice, the user is able to rotate each column and
press “Enter” key, so a should-surfer cannot perceive the password
by observing the 6 × 5 grid since there are too many password candidates. In this 6 × 5 grid space, maximally 6
5 = 7, 776 cases are
possible. This is the basic idea of the proposed password system
against shoulder-surfers.
Unfortunately there is a problem. If a shoulder-surfer can observe more than two grid plate configurations for a person, then the shoulder-surfer can reduce the searching space and guess the correct
password. Even though it is not easy to stealthily observe other’s more than once, this is one weakness
of implicit grid passwords.
Let me show one example with two observed configurations for a grid password. The user password
is ‘COMPU’, but ‘DPMAG’ is also one candidate password derived from the following configuration.
Figure 3. Both of ‘COMPU’ and ‘DPMAG’ are feasible password .
You are given two configurations of grid password from a shoulder-surfer. Suppose that you have
succeeded to stealthily record snapshots of the target person’s device (e.g. smart phone). Then your
next task is to reconstruct all possible passwords from these two snapshots. Since there are lots of
password candidates, you are asked for the k-th password among all candidates in lexicographical
order. In Figure 3, let us show the first 5 valid password. The first 5 valid passwords are ‘ABGAG’ ,
‘ABGAS’, ‘ABGAU’, ‘ABGPG’ and ‘ABGPS’.
The number k is given in each test case differently. If there does not exist a k-th password since k
is larger than the number of all possible passwords, then you should print ‘NO’ in the output.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. The first line of each test case contains one integer, K,
the order of the password you should find. Note that 1 ≤ K ≤ 7, 777. Next the following 6 lines show
the 6 rows of the first grid and another 6 lines represent the 6 rows of the second grid.
Output
Your program is to write to standard output. Print exactly the k-th password (including ‘NO’) in one
line for each test case.
The following shows sample input and output for three test cases.
Sample Input
3
1
AYGSU
DOMRA
CPFAS
XBODG
WDYPK
PRXWO
CBOPT
DOSBG
GTRAR
APMMS
WSXNU
EFGHI
5
AYGSU
DOMRA
CPFAS
XBODG
WDYPK
PRXWO
CBOPT
DOSBG
GTRAR
APMMS
WSXNU
EFGHI
64
FGHIJ
EFGHI
DEFGH
CDEFG
BCDEF
ABCDE
WBXDY
UWYXZ
XXZFG
YYFYH
EZWZI
ZGHIJ
Sample Output
ABGAG
ABGPS
NO

【分析】 具体没啥分析可言…
就是输出第k字典序的时候用了紫书上讲的递推输出法,相比暴力枚举字典序高效了很多
最多在说一下去重,unique函数的去重实际上是将重复的元素放到后面去了,并且返回第一个“无用”元素的位置,比如1122345 unique完了之后是1234512 返回值是后面那个1 的位置,配合vector的erase函数,去掉
第一次写没有去重,好吧,我以为不会有重复…

// 2020年1月31日14:59:17   
// 每个vector数组要去重  第一次死在这上面了 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<algorithm>
#define Maxn 10
using namespace std;
char A[Maxn][Maxn],B[Maxn][Maxn];
vector<char> v[6];

void solve(int dep,int i,int k) {
	if(dep == 6) return ;
	int tot = 1;
	for(int j=dep+1; j<=5; j++) tot *=v[j].size();
	while(k > tot) k -= tot,i++;
	printf("%c",v[dep][i]);
	solve(dep + 1, 0, k);
	return ;
}

inline bool cmp(char a,char b) {
	return a < b;
}

int main(int argc,char* argv[]) {
	//freopen("1.in","r",stdin);
	//freopen("1.out","w",stdout);
	int T,k; scanf("%d",&T);
	while(T--) {
		scanf("%d",&k);
		for(int i=1; i<=5; i++) v[i].clear();
		for(int i=1; i<=6; i++) scanf("%s",A[i] + 1);
		for(int i=1; i<=6; i++) scanf("%s",B[i] + 1);
		for(int i=1; i<=5; i++) {// lie
			for(int j=1; j<=6; j++) // A - hang
				for(int k=1; k<=6; k++) // B - hang
					if(A[j][i] == B[k][i]) {
						v[i].push_back(B[k][i]); break;
					}
		}
		int tot = 1;
		for(int i=1; i<=5; i++) {
			sort(v[i].begin(),v[i].end(),cmp);
			v[i].erase(unique(v[i].begin(),v[i].end()), v[i].end());
			//for(int j=0; j<v[i].size(); j++) printf("%c",v[i][j]);
			//printf("==\n");
			tot *= v[i].size();
		}
		if(tot < k) printf("NO\n");
		else { solve(1,0,k); printf("\n"); }
	}
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值