A - Palindrome

27 篇文章 0 订阅
19 篇文章 0 订阅

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, “Can you propose an efficient algorithm to find the length of the largest palindrome in a string?”

A string is said to be a palindrome if it reads the same both forwards and backwards, for example “madam” is a palindrome while “acm” is not.

The students recognized that this is a classical problem but couldn’t come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said “Okay, I’ve a better algorithm” and before he starts to explain his idea he stopped for a moment and then said “Well, I’ve an even better algorithm!”.

If you think you know Andy’s final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.
Input
Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string “END” (quotes for clarity).
Output
For each test case in the input print the test case number and the length of the largest palindrome.
Sample Input
abcbabcbabcba
abacacbaaaab
END
Sample Output
Case 1: 13
Case 2: 6

#include <iostream>
#include <cstring>
#include <cstdio>


using namespace std;
const int Mod = 1e9 + 7;
const int Maxn = 1000010;
char s[Maxn << 1],tmp[Maxn << 1];
int Len[Maxn << 1];
int Trans(char *st) {
    int i,len = strlen(st);
    tmp[0] = '@';
    for(i=1; i<=len*2; i+=2) {
        tmp[i] = '#';
        tmp[i + 1] = st[i >> 1];
    }
    tmp[len << 1 | 1] = '#';
    tmp[(len << 1 | 1) + 1] = '$';
    tmp[len * 2 + 3] = 0;
    return len << 1 | 1;
}


int Manacher(char * st,int len) {
    int mx = 0,Ans = 0,id = 0;
    for(int i=1; i<=len; i++) {
        if(mx > i)
            Len[i] = min(mx - i,Len[2 * id - i]);
        else Len[i] = 1;
        while(st[i - Len[i]] == st[i + Len[i]]) Len[i]++;
        if(Len[i] + i > mx) {
            mx = Len[i] + i;
            id = i;
        }
        Ans = max(Ans,Len[i]);
    }
    return Ans - 1;
}

int main(int agrc,char* agrv[]) {
    int kase = 0,Ans;
    while(scanf("%s",s ) == 1) {
        if(strcmp(s,"END") == 0) break;
        int len = Trans(s);
        Ans = Manacher(tmp,len);
        printf("Case %d: %d\n",++kase,Ans);
    }

    return 0;
}

https://blog.csdn.net/xiaoxiede_wo/article/details/79817998

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值