POJ 3461 Oulipo

27 篇文章 0 订阅

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 62133 Accepted: 23967
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output

1
3
0
Source

BAPC 2006 Qualification

题目大意:
求模式串在下面的字符串中出现了多少次,KMP模板题,但是没有复习KMP,拿Hash写 比较坑得一点就是 用Mod 会TLE,最坑的一点就是 Pod本来写的17 会WA,改成31 37 都可以AC,操蛋、。、、

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define LL unsigned long long
#define Maxn 1000005
const LL Mod = 1e9 + 7;
const int Pod = 31;
LL xp[10005],hass[Maxn];
char s[Maxn],sp[Maxn];
int main(int argc,char* argv[]) {
    int T; scanf("%d",&T);
    xp[0] = 1;
    for(int i=1; i<=10000; i++) xp[i] = (xp[i - 1] * Pod) ;
    while(T--) {
        memset(sp,0,sizeof(sp));
        memset(s,0,sizeof(s));
        scanf("%s",sp);
        //memset(hass,0,sizeof(hass));
        scanf("%s",s);
        int Ans = 0,len1 = strlen(sp);
        LL id = 0;
        for(int i=0; i<len1; i++) id = (id * Pod + (sp[i])) ;

        int len = strlen(s);
        hass[0] = s[0] ;
        for(int i=1; i<len; i++)
            hass[i] = (hass[i - 1] * Pod + s[i]) ;

        if(hass[len1 - 1] == id) Ans ++;

        for(int l=1,r=len1; r<len; r++,l++) {
            LL identiy = ((hass[r] - hass[l - 1] * xp[len1] )  ) ;
            if(identiy == id) Ans ++;
        }
        printf("%d\n",Ans);
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值