POJ3126 Prime Path 质数变换

37 篇文章 0 订阅

Prime Path

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40556 Accepted: 21520
Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input

3
1033 8179
1373 8017
1033 1033
Sample Output

6
7
0
Source

Northwestern Europe 2006

题目大意
给出n,m两个数字,每次可以改变n中某一位的一个数字,但是每次变换之后的数字也必须是质数,求最少多少次可以从n变成m

题目分析:
直接就四种状态 每次尝试改变个位、十位、百位、千位,**的是,没有写了Prime函数却没有调用,居然1A

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define Maxn 10001
using namespace std;
int prime[Maxn],tot = 0;
bool is_prime[Maxn],exist[Maxn];
int dis [Maxn];
void Make_Prime() {
    memset(is_prime,0,sizeof(is_prime));
    memset(prime,0,sizeof(prime));
    for(int i=2; i<Maxn; i++) {
        if(!is_prime[i] ) prime[++tot] = i;
        for(int j=1; j<=tot && prime[j] * i <Maxn; j++) {
            is_prime[prime[j] * i] = true;
            if(i % prime[j] == 0) break;
        }
    }
    return ;
}

int main(int argc,char* argv[]) {
    int T,n,m;
    scanf("%d",&T);
    Make_Prime();
    while(T--) {
        scanf("%d %d",&n,&m);
        queue<int > q;

        while(!q.empty()) q.pop();
        memset(dis,-1,sizeof(dis));
        memset(exist,0,sizeof(exist));
        q.push(n);  dis[n] = 0;  exist[n] = 1;

        while(!q.empty()) {
            int num = q.front(); q.pop(); exist[num] = 0;
            if(num == m) { printf("%d\n",dis[m]); break; }
            int t = num / 10,p;
            for(int i=0; i<=9; i++) {// 灏濊瘯灏嗕釜浣嶆暟 鍙樻垚 i
                int temp = t * 10 + i;
                if(is_prime[temp]) continue;
                if(dis[temp] == -1 || dis[temp] > dis[num] + 1) { // 娌℃湁鏇存柊杩? 鎴栬€? 褰撳墠绛栫暐鏇翠紭
                    dis[temp] = dis[num] + 1;
                    if(!exist[temp]) { q.push(temp); exist[temp] = 1; }
                }
            }
            t = num / 100 , p = num % 10;
            for(int i=0; i<=9; i++) { // 鍗佷綅鏁?
                int temp = t * 100 + i * 10 + p;
                if(is_prime[temp]) continue;
                if(dis[temp] == -1 || dis[temp] > dis[num] + 1) {
                    dis[temp] = dis[num] + 1;
                    if(!exist[temp]) { q.push(temp); exist[temp] = 1; }
                }
            }
            t = num / 1000, p  = num % 100;
            for(int i=0; i<=9; i++) {
                int temp = t * 1000 + i * 100 + p;
                if(is_prime[temp]) continue;
                if(dis[temp] == -1 || dis[temp] > dis[num] + 1) {
                    dis[temp] = dis[num] + 1;
                    if(!exist[temp]) { q.push(temp); exist[temp] = 1; }
                }
            }
            t = num % 1000;
            for(int i=1; i<=9; i++) {
                int temp = i * 1000 + t;
                if(is_prime[temp]) continue;
                if(dis[temp] == -1 || dis[temp] > dis[num] + 1) {
                    dis[temp] = dis[num] + 1;
                    if(!exist[temp]) { q.push(temp); exist[temp] = 1; }
                }
            }
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值