ZOJ 2588 Burning Bridges

Burning Bridges

Time Limit: 5 Seconds Memory Limit: 32768 KB
Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.
But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.
Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.
So they came to you and asked for help. Can you do that?

Input

The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. T test cases follow, each preceded by a single blank line.
The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.

Output

On the first line of each case print K - the number of bridges that will certainly not be burned. On the second line print K integers - the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input.
Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.

Sample Input

2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

Sample Output

2
3 7

1
4

/*
这个题有坑  加边的时候有重边  注意一下  刚开始被坑了 
还有就是 head 数组初始值赋0 可能会报错 用-1 为妙
啊 还有 Segmentation Fault  这是ZOJ特有的 报错吗
有道翻译给出的结果是:内存区段错误 
*/
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
#define maxn 10020
#define maxm 10055
struct Edge{ int to,w,next,id; }e[maxm*20];
int dfn[maxn*2],low[maxn*2],visx,n,m;
int head[maxn],tot,ans[maxm*2],cnt;
void init(){
    memset(head,-1,sizeof head );
    tot=0;visx=0;cnt=0;
    memset(dfn,0,sizeof dfn );
    memset(low,0,sizeof low );
    return ;
}
void Add_Edge(int u,int v,int id){
    int i;
    for(i=head[u];i!=-1;i=e[i].next) if(e[i].to==v) break;
    if(i!=-1){ e[i].w=1;  return; }
    e[tot].to=v;e[tot].next=head[u];e[tot].w=0;e[tot].id=id;head[u]=tot++;
    return;
}
void Tarjan(int u,int father){
    dfn[u]=low[u]= ++visx;
    for(int i=head[u];i!=-1;i=e[i].next){
        int v=e[i].to;
        if(!dfn[v]){
            Tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u]&&!e[i].w)
                ans[++cnt]=e[i].id;
        }
        else if(v!=father)
            low[u]=min(low[u],dfn[v]);
    }
    return ;
}
int main(){
    int T,cas=0;
    cin>>T;
    while(T--){
        init();
        scanf("%d%d",&n,&m);
        for(int u,v,i=1;i<=m;i++){
            scanf("%d%d",&u,&v);
            Add_Edge(u,v,i);
            Add_Edge(v,u,i);
        }
        Tarjan(1,0);
        printf("%d\n",cnt);
        sort(ans+1,ans+1+cnt);
        if(cnt){  
            for(int i=1;i<=cnt;i++){
                if(i==1) printf("%d",ans[i]);  
                else printf(" %d",ans[i]);  
            }  
            cout<<endl;
        }
        if(T) cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值