POJ 3694 Network 割边+LCA

37 篇文章 0 订阅

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can’t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input
The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output
For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input
3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0
Sample Output
Case 1:
1
0

Case 2:
2
0

/*
这题的大概思路就是,先求割边并标记,然后缩点,形成一棵树,然后把这颗树上各个
结点的父结点用dfs求出来,再然后就是LCA了,因为加入某条边后,
树内会形成一个圈,这个圈上所有的边将不再是桥,可以发现跟LCA的关联。
求LCA用裸的方法就行,比较直观些,也好操作。
实际上,这道题也不一定要缩点,如果用缩点的思路来做的话,程序将十分麻烦。
可以直接根据dfn值来进行LCA。因为,我们观察low[v] > dfn[u]这个条件,
代表的意思就是v无法通过回边或者通过子女到达比u点更靠前的点,那么我们只需要标记v
点即可表明割边。在进行LCA时,由于树的组成就是原图中的割边,所以在原图中,
根据这个标记来判断是否将割边被转化为了普通边。 
*/
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
#include<cstdio>
using namespace std;
#define maxn 100005
#define maxm 555555
#define INF 1000000000
struct Edge{ int v,next; }e[maxm];
int low[maxn],dfn[maxn],dep[maxn],vis[maxn],visx;
int tot,n,m,head[maxn];
int cnt,bridge[maxn],fa[maxn];
void Init(){
    cnt=0;tot=0;visx=0;
    memset(vis,0,sizeof vis );
    memset(dfn,0,sizeof dfn );
    memset(dep,0,sizeof dep );
    memset(bridge,0,sizeof bridge );
    memset(head,-1,sizeof head );
    for(int i=1;i<=n;i++) fa[i]=i;
}
void Add_Edge(int u,int v){ e[tot].v=v;e[tot].next=head[u];head[u]=tot++; }
void Tarjan(int u){
    dfn[u] = low[u] = ++visx;
    dep[u] = dep[fa[u]] +1;
    for(int i=head[u];i!=-1;i=e[i].next){
        int v=e[i].v;
        if(!dfn[v]){
            fa[v]=u;
            Tarjan(v);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u]) cnt++,bridge[v]=1;//u-v鍓茶竟
        }
        else if(v!=fa[u]) low[u]=min(low[u],dfn[v]);
    }
}
void LCA(int u,int v){
    while(dep[u]>dep[v]){
        if(bridge[u]) cnt--,bridge[u]=0;
        u=fa[u];
    }
    while(dep[v]>dep[u]){
        if(bridge[v]) cnt--,bridge[v]=0;
        v=fa[v];
    }
    while(u!=v){
        if(bridge[u]) cnt--,bridge[u]=0;
        if(bridge[v]) cnt--,bridge[v]=0;
        u=fa[u];v=fa[v];
    }
}
void Ask(){
    int q,u,v;
    scanf("%d",&q);
    while(q--){
        scanf("%d%d",&u,&v);
        LCA(u,v);
        printf("%d\n",cnt);
    }
    printf("\n");
}
int main(){
    int cas=0;
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0) break;
        printf("Case %d:\n", ++cas);
        Init();
        for(int u,v,i=1;i<=m;i++){
            scanf("%d%d",&u,&v);
            Add_Edge(u,v);Add_Edge(v,u);
        }
        Tarjan(1);
        Ask();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值