POJ 3013 Big Christmas Tree

37 篇文章 0 订阅

Big Christmas Tree
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 24251 Accepted: 5260
Description

Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.
这里写图片描述
The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers v, e (0 ≤ v, e ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers a, b, c indicating the edge which is able to connect two nodes a and b, and unit price c.

All numbers in input are less than 216.

Output

For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

Sample Input

2
2 1
1 1
1 2 15
7 7
200 10 20 30 40 50 60
1 2 1
2 3 3
2 4 2
3 5 4
3 7 2
3 6 3
1 5 9
Sample Output

15
1210
Source

POJ Monthly–2006.09.29, Kim, Chan Min (kcm1700@POJ)

SPFA

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<queue>
using namespace std;
const int maxn = 50010;
#define LL long long
LL dis[maxn];
bool exist[maxn];
int head[maxn],n,m,weight[maxn],tot;
queue<int> q;
const long long INF=9999999999;
//我这里INF用了10个9,刚开始用199999999偏小导致WA 
struct Edge{ int to,next;LL weight; }e[maxn<<1];
void Add_Edge(int u,int v,LL w){
    e[++tot].to=v;e[tot].weight=w;
    e[tot].next=head[u];head[u]=tot;
}
LL SPFA(){
    while(!q.empty()) q.pop();
    for(int i=1;i<=n;i++){
        dis[i]=INF;
        exist[i]=false;
    }
    q.push(1);dis[1]=0;exist[1]=1;
    while(!q.empty()){
        int u=q.front();q.pop();exist[u]=false;
        for(int i=head[u];i!=-1;i=e[i].next){
            int v=e[i].to;LL w=e[i].weight;
            if(dis[v]>dis[u]+w){
                dis[v]=dis[u]+w;
                if(!exist[v]) q.push(v),exist[v]=true;
            }
        }
    }
    LL ans=0;
    for(int i=1;i<=n;i++){
        if(dis[i]==INF) return 0;
        else ans+=weight[i]*dis[i];
    }
    return ans;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        tot=0;
        memset(head,-1,sizeof head );
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%d",&weight[i]);
        LL w;int u,v;
        for(int i=1;i<=m;i++){
            scanf("%d%d%I64d",&u,&v,&w);
            Add_Edge(u,v,w);Add_Edge(v,u,w);
        }
        if(n==0||n==1){printf("0\n");continue;}
        LL ans=SPFA();
        if(ans==0) printf("No Answer\n");
        else printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值