【ACM】HDU 2105 The Center of Gravity(for java)

Problem Description

Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked 
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center 
of gravity of the triangle?

 

Input

The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.

 

Output

For each case, print the coordinate, accurate up to 1 decimal places.

 

Sample Input

2 1.0 2.0 3.0 4.0 5.0 2.0 1.0 1.0 4.0 1.0 1.0 5.0 0

 

Sample Output

3.0 2.7 2.0 2.3

 

重心的坐标是顶点坐标的算术平均

这道题注意键盘录入

只有在输入0时才能结束

AC代码:

import java.util.Scanner;

public class Main{

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		
		Scanner scanner = new Scanner(System.in);

		double x1,y1,x2,y2,x3,y3,res1,res2;
		
		while(scanner.hasNext()) {
			int N = scanner.nextInt();
			if(N ==0)
				break;
			while((N--)  != 0) {
				x1 = scanner.nextDouble();
				y1 = scanner.nextDouble();
				x2 = scanner.nextDouble();
				y2 = scanner.nextDouble();
				x3 = scanner.nextDouble();
				y3 = scanner.nextDouble();
				
				res1 = (x1+x2+x3) / 3;
				res2 = (y1+y2+y3) / 3;

				System.out.println(String.format("%.1f", res1) +" " + String.format("%.1f", res2));

			}			
		}
	
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值