HDU - 4352 XHXJ's LIS

传送门:点击打开链接

XHXJ's LIS

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3715    Accepted Submission(s): 1548


Problem Description
#define xhxj (Xin Hang senior sister(学姐)) 
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life: 
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
 

Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<2 63-1 and 1<=K<=10).
 

Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
 

Sample Input
 
 
1123 321 2
 

Sample Output
 
 
Case #1: 139
 

动态规划的一道较为综合的题,融合了数位dp和状压dp

dp[pos][sta][k]表示数的遍历到第pos位,状态为sta,k值已定的情况下的最大值

#include<iostream>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<cstdio>
#include<vector>
#include<climits>
using namespace std;
typedef long long ll;
int a[20], k;
ll dp[20][1 << 10][11];
int New(int sta, int i)
{
    for(int it = i; it <= 9; it++)
    {
        if((sta >> it) & 1)
        {
            sta ^= (1 << it);
            break;
        }
    }
    return sta | (1 << i);
}
int get(int sta)
{
    int cnt = 0;
    for(int i = 9; i >= 0; i--)
        if((sta >> i) & 1) cnt++;
    return cnt;
}
ll dfs(int sta, bool limit, bool lead, int pos)
{
    if(pos == -1)
        return get(sta) == k;
    if(!limit && !lead && dp[pos][sta][k] != -1)
        return dp[pos][sta][k];
    int up = limit ? a[pos]:9;
    ll ans = 0LL;
    for(int i = 0; i <= up; i++)
    {
        ans += dfs(lead && i == 0 ? 0 : New(sta, i), limit && i == a[pos], lead && i == 0, pos - 1);
    }
    if(!lead && !limit) dp[pos][sta][k] = ans;
    return ans;
}
ll solve(ll x)
{
    if(x == 0)
    {
        if(k == 1) return 0;
        else return 0;
    }
    if(x < 0)
        return 0;
    int pos = 0;
    while(x)
    {
        a[pos++] = x % 10;
        x /= 10;
    }
    return dfs(0, true, true, pos - 1);
}
int main()
{
    int t, kase = 0;
    ll l, r;
    scanf("%d", &t);
    memset(dp, -1, sizeof(dp));
    while(t--)
    {
        kase++;
        scanf("%lld%lld%d", &l, &r, &k);
        printf("Case #%d: %lld\n", kase, solve(r) - solve(l-1));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值