HDU 5821 Ball

5 篇文章 0 订阅
2 篇文章 0 订阅

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 701    Accepted Submission(s): 422


Problem Description

ZZX has a sequence of boxes numbered 1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1in , if the i -th box is empty then a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input

First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output

For each testcase, print "Yes" or "No" in a line.
 

Sample Input

  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output

  
  
No No Yes No Yes
 

题意

    n个盒子,每个盒子中最多一个球,球有不同的颜色,用不同的数表示,执行m次操作,每次把第lf个盒子到rt个盒子中的球拿出,再随机放回去,问m次操作之后,是否会得到指定的结果。

思路

    最初我的想法是将lf到rt中的数排序,同时也将目标数组中相同区间的数排序,看m次操作之后,两个数组是否相同。样例没问题,但提交之后WA,没仔细分析问题在哪,不过因为两个数组都要排序,时间可能会超。参看题解的思路,在输入目标数组时,给初始数组的数据标上相应的序号,比如最后一个样例
a[i].v:  1 1 2 2 0
对应目标数组
a[i].id:3 4 1 2 5,也就是说a[1]对应数组b的第3个位置,a[2]对应第4个位置……
然后对数据接序号排序,看a[i]==i?如果有一个不等,显然就是No


#include <iostream>
#include <algorithm>
using namespace std;
#define N 1005
struct ball
{
	int v,id;
}a[N],b[N];
int t,n,m,lf,rt;
int cmp(struct ball a,struct ball b)
{
	return a.id<b.id;
}
int main()
{
	cin>>t;
	while(t--)
	{
		int f=0;
		cin>>n>>m;<span style="white-space:pre">		</span>//n个盒子,m次操作
		for(int i=1;i<=n;i++)<span style="white-space:pre">	</span>//输入开始的原始数据,位置值设为0
		{
		  cin>>a[i].v;
		  a[i].id=0;
		}
		for(int i=1;i<=n;i++)<span style="white-space:pre">	</span>//输入目标数组,并求出原始数组的目标序号
		{
			cin>>b[i].v;
			for(int j=1;j<=n;j++)
			  if(a[j].v==b[i].v&&!a[j].id)
			  {
			    a[j].id=i;
			    break;
			  }
		}
		for(int i=1;i<=m;i++)<span style="white-space:pre">	</span>//执行m次操作,按给定的区间排序
		{
			cin>>lf>>rt;
			sort(a+lf,a+rt+1,cmp);
		}
		for(int i=1;i<=n;i++)<span style="white-space:pre">	</span>//依次比较序号值
		  if(a[i].id!=i)
		  {
		    f=1;
		    break;
		  }
		if(f)
		  cout<<"No\n";
		else
		  cout<<"Yes\n";   
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值