HDOJ_1005_Number Sequence

题目:A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5


这道题目当看到式子的时候,第一反应是递归,但是乌拉拉写完后,一提交出现了Time Limit Exceeded错误,超出了oj平台规定时间。翻看了各家博客,发现这个题目另有玄机。

这道题目的核心思想是循环列,式子最后的%7,可以得出f(n)有0,1,2,3,4,5,6这7种情况。
由于f(n)是由f(n-1)和f(n-2)计算得出,f(n-1)和f(n-2)共有7*7=49种组合情况。因此会形成一个循环列,这样我们只需计算出每对A,B值对应的循环列的值,最终结果f(n)=f(n%(循环列的长度))。

这里涉及到一个抽屉原理,大家有空可以查看一下。


代码如下:

#include <iostream>

using namespace std;

int main(){
    int a,b,n;
    int result[51];

    while(cin>>a>>b>>n){

        if(a==0&&b==0&&n==0){
            break;
        }else{
            result[1] = 1;
            result[2] = 1;
            int i;
            for( i = 3;i<50;i++){
                result[i]=(a*result[i-1]+b*result[i-2])%7;
                if(result[i] == 1&&result[i-1] == 1) break;
            }
            n = n%(i-2);
            if(n==0) cout<<result[i-2]<<endl;   
            else cout<<result[n]<<endl;
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值