K - 滑雪
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
Input
1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9Sample Output
25
思路:dfs搜一遍,还要记忆化,否则或超时
代码:
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
typedef long long ll;
int r,c;
int tu[105][105];
int dp[105][105];
int dx[4]={0,0,-1,1};
int dy[4]={1,-1,0,0};
bool check(int x,int y,int cp){
if(x<1||y<1||x>r||y>c||cp<=tu[x][y]) return 0;
else return 1;
}
int dfs(int x,int y){
if(dp[x][y]) return dp[x][y];
int ans = 0;
for(int i=0;i<4;i++){
int xx = dx[i]+x;
int yy = dy[i]+y;
if(!check(xx,yy,tu[x][y])) continue;
int tmp = dfs(xx,yy);
ans = max(ans,tmp);
}
dp[x][y] = ans+1;
return dp[x][y];
}
int main(){
while(cin>>r>>c){
memset(dp,0,sizeof(dp));
int maxx = -1;
int sx,sy;
for(int i=1;i<=r;i++){
for(int j=1;j<=c;j++){
cin>>tu[i][j];
}
}
//cout<<sx<<" "<<sy<<endl;
int ans = -1 ;
for(int i=1;i<=r;i++){
for(int j=1;j<=c;j++){
ans = max(ans,dfs(i,j));
}
}
cout<<ans<<endl;
}
return 0;
}