E Sequence in the Pocket

题源:http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5993

DreamGrid has just found an integer sequence  in his right pocket. As DreamGrid is bored, he decides to play with the sequence. He can perform the following operation any number of times (including zero time): select an element and move it to the beginning of the sequence.

What's the minimum number of operations needed to make the sequence non-decreasing?

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer  (), indicating the length of the sequence.

The second line contains  integers  (), indicating the given sequence.

It's guaranteed that the sum of  of all test cases will not exceed .

Output

For each test case output one line containing one integer, indicating the answer.

Sample Input

2
4
1 3 2 4
5
2 3 3 5 5

Sample Output

2
0

Hint

For the first sample test case, move the 3rd element to the front (so the sequence become {2, 1, 3, 4}), then move the 2nd element to the front (so the sequence become {1, 2, 3, 4}). Now the sequence is non-decreasing.

For the second sample test case, as the sequence is already sorted, no operation is needed.

[分析]

         开始的时候我是这么想的:

         (1)开两个数组 A[ ]   B[ ]   设置 ans=0

         (2)A[ ] 数组存储单增的元素列   B[ ]数组存储那些一定要拿到队首进行改变的元素假设有 x 个 x 可以为0,ans+=x 

         (3)把B数组中的 bi 元素从大到小依次在A数组中找到 >= bi  的元素的位置 y,  ans+=y,  当 bi  <= A[0]时 则终止跳出 输出                    ans

错误的代码:

  

#include <iostream>
#include <queue>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn=100005;
int n;
int t;
int a[maxn];
int b[maxn];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        int f=0,cnt=0;
        int num=0;
        memset(a,0,sizeof 0);
        memset(b,0,sizeof 0);
        scanf("%d",&n);
        scanf("%d",&a[f]);f++;
        int x=0;
        for(int i=1;i<n;i++)
        {
            scanf("%d",&x);
            if(x>=a[f-1]) a[f++]=x;
            else b[cnt++]=x;
        }
        sort(b,b+cnt);
        num=cnt;
        if(cnt==0)
        {
            printf("0\n");
            continue;
        }
        if(b[cnt-1]<=a[0])
        {
            printf("%d\n",cnt);
            continue;
        }
        else
        {
                for(int i=cnt-1;i>=0;i--)
                num+=(lower_bound(a,a+f,b[i])-a);
                printf("%d\n",num);
        }
    }
    return 0;
}

  这个思路错在并不是 B[ ] 数组中的所有元素都要重新在进行一遍 

 num+=(lower_bound(a,a+f,b[i])-a); 

   操作。也就是说B[ ]数组中的最大值元素后面还可能会有其他的A[ ] 数组元素进行调到队头这一步操作,所以只需要求B[ ] 中最大元素 num+=(lower_bound(a,a+f,b[cnt-1])-a); 就可以了。

#include <iostream>
#include <queue>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn=100005;
int n;
int t;
int a[maxn];
int b[maxn];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        int f=0,cnt=0;
        int num=0;
        memset(a,0,sizeof 0);
        memset(b,0,sizeof 0);
        scanf("%d",&n);
        scanf("%d",&a[f]);f++;
        int x=0;
        for(int i=1;i<n;i++)
        {
            scanf("%d",&x);
            if(x>=a[f-1]) a[f++]=x;
            else b[cnt++]=x;
        }
        sort(b,b+cnt);
        num=cnt;
        if(cnt==0)
        {
            printf("0\n");
            continue;
        }
        if(b[cnt-1]<=a[0])
        {
            printf("%d\n",cnt);
            continue;
        }
        else
        {

                num+=(lower_bound(a,a+f,b[cnt-1])-a);
                printf("%d\n",num);
        }
    }
    return 0;
}

 从这道题目中我觉得不应该轻易地放弃自己的原有思路,自己原有的思路并不一定全部都不对,可能只是中间有一步没有想完整,那我们就全盘否定转别的思路可能就会耗更多的时间在心理上也对自己产生不小的压力。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值