POJ 2386 Lake Counting

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17917 Accepted: 9069
Description
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output
  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input
    10 12
    W……..WW.
    .WWW…..WWW
    ….WW…WW.
    ………WW.
    ………W..
    ..W……W..
    .W.W…..WW.
    W.W.W…..W.
    .W.W……W.
    ..W…….W.
    Sample Output
    3
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N = 105;
int m,n;
char field[N][N+1];

void dfs(int x , int y){
    field[x][y] = '.';

    for(int dx = -1 ; dx <=1 ; dx++){
        for(int dy = -1 ; dy <=1 ; dy++){
            int nx = x+dx;
            int ny = y + dy;
            if(0<=nx&&nx<n&&0<=ny&&ny<m&&field[nx][ny]=='W')
                dfs(nx,ny);
        }
    }
}
int main(){
    int res,i,j;
    while(~scanf("%d%d",&n,&m))
    {
        res=0;
        for(i=0;i<n;i++)
            scanf("%s",field[i]);
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
                if(field[i][j]=='W')
                {
                    dfs(i,j);
                    res++;
                }
        printf("%d\n",res);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值