堆的判断|heaps_1147

描述

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap

指定输入

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

指定输出

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

示例

示例输入

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

示例输出

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

分析

分析点一:数组转二叉树算法

这个算法主要是利用队列,因为这个是判断堆的,所以都是最后一层的叶子节点总在最左边,但是有些情况是有空节点的,这样只要判断一下就好了

分析点二:堆

  • 性质一:最大堆的根节点的值是最大的,最小堆的根节点的值是最小的
  • 最大堆的定义:每一个节点的值大于等于它的左右子节点的值,且树是最优平衡的,最后一层的叶子节点在最左边(最小堆将大于等于改为小于等于即可,粗体表示暂时还未搞懂)
  • 当用数组表示法来表示树时,最大堆判定算法如下

如果是链式的树按定义判断就行了

代码

class Node:

    def __init__(self):
        self.data = None
        self.left_node = None
        self.right_node = None


class GenTree:

    def __init__(self, array):
        self.array = array
        self.root = None
        self.max_heap = True
        self.min_heap = True
        self.result = []

    def genbtree(self):
        if len(self.array) == 0:
            return
        count = 0
        queue = []
        root = Node()
        root.data = self.array[0]
        self.root = root
        queue.append(root)
        count += 1
        while len(queue) > 0:
            current_node = queue.pop(0)
            if count < len(self.array):
                current_node.left_node = Node()
                current_node.left_node.data = self.array[count]
                count += 1
                queue.append(current_node.left_node)
            if count < len(self.array):
                current_node.right_node = Node()
                current_node.right_node.data = self.array[count]
                count += 1
                queue.append(current_node.right_node)

    def judge(self, root):
        if root is None:
            return
        if root.left_node is not None:
            if root.data >= root.left_node.data:
                self.min_heap = False
            elif root.data <= root.left_node.data:
                self.max_heap = False
        if root.right_node is not None:
            if root.data >= root.right_node.data:
                self.min_heap = False
            elif root.data <= root.right_node.data:
                self.max_heap = False
        self.judge(root.left_node)
        self.judge(root.right_node)
        self.result.append(root.data)


n, m = map(int, input().split(" "))
for i in range(n):
    array = list(map(int, input().split(" ")))
    gentree = GenTree(array)
    gentree.genbtree()
    gentree.judge(gentree.root)
    if gentree.max_heap and not gentree.min_heap:
        print("Max Heap")
        for j in range(m):
            if j == m - 1:
                print(gentree.result[j])
                break
            print(gentree.result[j], end=" ")
    elif gentree.min_heap and not gentree.max_heap:
        print("Min Heap")
        for j in range(m):
            if j == m - 1:
                print(gentree.result[j])
                break
            print(gentree.result[j], end=" ")
    else:
        print("Not Heap")
        for j in range(m):
            if j == m - 1:
                print(gentree.result[j])
                break
            print(gentree.result[j], end=" ")

??正文结束??
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值