1147. Heaps (30)
时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 100), the number of trees to be tested; and N (1 < N <= 1000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, print in a line “Max Heap” if it is a max heap, or “Min Heap” for a min heap, or “Not Heap” if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
思路:如果用数组存储堆并且从下标1开始存放数据,那么将存在这样的一个规律:假设一个顶点的下表为i,则下标为2*i对应的数据就是此顶点的左孩子,下标为2*i+1对应的数据就是此顶点的右孩子,因此可以运用此规律,后序的时候,同样可以运用此规律
1、对于判断大顶堆或者小顶堆,可以设两个bool变量,以此来判断,如果当前节点比孩子节点小,所有的节点都是这样,那么一定是小顶堆,因此只要当前节点比孩子节点小,就把小顶堆bool变量置1,反之则把大顶堆bool变量置1。那么结果也容易得到,如果两个当中一个变量为true,那这组数据一定是堆,如果两个变量值相同,那么则不属于堆。
#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
using namespace std;
const int Maxn = 1010;
int heap[Maxn], N, M;
void Juede(int idx, bool & maxHeap, bool & minHeap) {
int u = 2 * idx, v = u + 1;
if (u <= M) {
if (heap[idx] < heap[u])minHeap = true;
else maxHeap = true;
Juede(u, maxHeap, minHeap);
}
if (v <= M) {
if (heap[idx] < heap[v])minHeap = true;
else maxHeap = true;
Juede(v, maxHeap, minHeap);
}
}
int c;
void postOrder(int idx) {
if (idx > M) return;
int u = 2 * idx;
postOrder(u);
postOrder(u + 1);
printf("%d", heap[idx]);
if (++c != M)printf(" ");
}
int main() {
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
scanf("%d %d", &N, &M);
while (N--) {
for (int i = 1; i <= M; ++i) {
scanf("%d", &heap[i]);
}
bool maxHeap = false, minHeap = false;
Juede(1, maxHeap, minHeap);
if (maxHeap && !minHeap) printf("Max Heap\n");
else if (!maxHeap && minHeap) printf("Min Heap\n");
else printf("Not Heap\n");
c = 0;
postOrder(1);printf("\n");
}
return 0;
}