POJ 2387<BFS>

the reason of failure:1、MAXN定义太小了,虽然每条线的距离为100以内,但是有1000以内的线,所以存在1000*100的长度.

thinking:简单BFS找最短,但要注意长度这个问题.

题目:

A - Catch That Cow
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
代码:

#include <iostream>
#include <queue>
#define MAXN 99999

using namespace std;

int main(){
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	queue<int>qq;
	int n,m,i,j,k,t1,t2,t3;
	cin >> m >> n;
	int map1[n+5][n+5];
	int lowcost[n+5];
	for(i=1;i<=n;i++){
		for(j=1;j<=n;j++)
			map1[i][j]=MAXN;
		lowcost[i]=MAXN;
		}
	for(i=0;i<m;i++){
		cin >> t1 >> t2 >> t3;
		if(t3<map1[t1][t2]){
			map1[t1][t2]=t3;
			map1[t2][t1]=t3;
		}
	}
	lowcost[n]=0;
	qq.push(n);
	int a;
	while(!qq.empty()){
		a=qq.front();
		qq.pop();
		for(i=1;i<n;i++){
			if(map1[a][i]+lowcost[a]<lowcost[i]&&map1[a][i]!=MAXN&&lowcost[a]!=MAXN){
				lowcost[i]=lowcost[a]+map1[a][i];
				qq.push(i);
			}
		}
	}
	cout << lowcost[1] << endl;
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值