DP-最长上升序列

thinking:两个循环,找小于自身的那个数,也就是到这个找到的数有几个最大上升序列了,在原基础上加1.然后接着往前找,挑出最大值赋值到这个数.

如 1 3 9 2 6 11

每隔数初值为1.则3的最大上升序列为2,9的最大上升序列有(3的最大上升序列),(1的最大上升序列),找最大加1,则为3,那么2的最大上升序列为(1),则2的最大上升序列为2

.6的最大上升序列为(2的最大上升序列),(3的最大上升序列),(1的最大上升序列)找出最大,为(3),则6的最大上升序列为4,以此类推

题目:

 - Longest Ordered Subsequence
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence (  a1a2, ...,  aN) be any sequence (  ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
代码:

#include <iostream>
#define MAXN 99999
using namespace std;
int a1[MAXN],b1[MAXN];
int main(){
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	int n;
	int i,j,k,l;
	cin >> n;
	for(i=0;i<n;i++){
		cin >> a1[i];
		b1[i]=1;
	}	int maxn=1;
		for(i=0;i<n;i++){
			for(j=0;j<i;j++)
				if(a1[j]<a1[i]&&b1[i]<=b1[j])
					b1[i]=b1[j]+1;
					if(b1[i]>maxn)maxn=b1[i];
				}
				cout << maxn << endl;
		return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值