Pinball HDU - 6373
There is a slope on the 2D plane. The lowest point of the slope is at the origin. There is a small ball falling down above the slope. Your task is to find how many times the ball has been bounced on the slope.
It’s guarantee that the ball will not reach the slope or ground or Y-axis with a distance of less than 1 from the origin. And the ball is elastic collision without energy loss. Gravity acceleration g=9.8m/s2.
Input
There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases.
The first line of each test case contains four integers a, b, x, y (1 ≤ a, b, -x, y ≤
100), indicate that the slope will pass through the point(-a, b), the initial position of the ball is (x, y).
Output
Output the answer.
It's guarantee that the answer will not exceed 50.
Sample Input
1
5 1 -5 3
Sample Output
2
题意:
给定一个小球的坐标以及斜面上的一点,求小球在斜面上的碰撞次数。
转换坐标系之后,就变成了一个有水平加速度的平抛?运动?
如图
最后算次数的时候其实算错了o(* ̄▽ ̄*)o
应该是(T+1)/2 ?
附代码
#include <algorithm>
#include <iostream>
#include <math.h>
using namespace std;
const int N=1e5;
const double g=9.8;
int main(int argc, const char * argv[]) {
int t;
scanf("%d",&t);
while(t--)
{
double a,b,x,y;
scanf("%lf%lf%lf%lf",&a,&b,&x,&y);
x=-x;
double arc=atan(b/a);
// printf("%f\n",arc);
double pi=g*sin(arc);
double cu=g*cos(arc);
double h=(y-b/a*x)*cos(arc);
double pi_len=x/cos(arc)+h*sin(arc);
double cu_len=h;
// printf("%f %f\n",pi_len,cu_len);
double pi_t=sqrt(2*pi_len/pi);
double cu_t=sqrt(2*cu_len/cu);
//printf("%f %f\n",pi_t,cu_t);
int ans=(pi_t-cu_t)/cu_t;
printf("%d\n",(ans)/2+1);
}
}
对,我按纸上这么算AC不了(;´д`)ゞ