HDU 6373 Pinball 理想状态下,小球在斜面上的运动规律

 

Pinball HDU - 6373

There is a slope on the 2D plane. The lowest point of the slope is at the origin. There is a small ball falling down above the slope. Your task is to find how many times the ball has been bounced on the slope.

It’s guarantee that the ball will not reach the slope or ground or Y-axis with a distance of less than 1 from the origin. And the ball is elastic collision without energy loss. Gravity acceleration g=9.8m/s2. 
这里写图片描述
Input 
There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases.

The first line of each test case contains four integers a, b, x, y (1 ≤ a, b, -x, y ≤ 
100), indicate that the slope will pass through the point(-a, b), the initial position of the ball is (x, y). 
Output 
Output the answer.

It's guarantee that the answer will not exceed 50.

Sample Input

1
5 1 -5 3

Sample Output

2

题意:

给定一个小球的坐标以及斜面上的一点,求小球在斜面上的碰撞次数。

转换坐标系之后,就变成了一个有水平加速度的平抛?运动? 

如图

最后算次数的时候其实算错了o(* ̄▽ ̄*)o

应该是(T+1)/2 ?

附代码

#include <algorithm>
#include <iostream>
#include <math.h>
using namespace std;
const int N=1e5;
const double g=9.8;
int main(int argc, const char * argv[]) {
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double a,b,x,y;
        scanf("%lf%lf%lf%lf",&a,&b,&x,&y);
        x=-x;
        double arc=atan(b/a);
        //        printf("%f\n",arc);
        double pi=g*sin(arc);
        double cu=g*cos(arc);
        double h=(y-b/a*x)*cos(arc);
        double pi_len=x/cos(arc)+h*sin(arc);
        double cu_len=h;
        //        printf("%f %f\n",pi_len,cu_len);
        double pi_t=sqrt(2*pi_len/pi);
        double cu_t=sqrt(2*cu_len/cu);
        //printf("%f %f\n",pi_t,cu_t);
        int ans=(pi_t-cu_t)/cu_t;

        printf("%d\n",(ans)/2+1);
    }
}

对,我按纸上这么算AC不了(;´д`)ゞ

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值