HDU 6373 Pinball(暴力)

Pinball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 574    Accepted Submission(s): 249


 

Problem Description

There is a slope on the 2D plane. The lowest point of the slope is at the origin. There is a small ball falling down above the slope. Your task is to find how many times the ball has been bounced on the slope.

It's guarantee that the ball will not reach the slope or ground or Y-axis with a distance of less than 1 from the origin. And the ball is elastic collision without energy loss. Gravity acceleration g=9.8m/s2.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 100), indicating the number of test cases.

The first line of each test case contains four integers a, b, x, y (1 ≤ a, b, -x, y ≤ 100), indicate that the slope will pass through the point(-a, b), the initial position of the ball is (x, y).

 

 

Output

Output the answer.

It's guarantee that the answer will not exceed 50.

 

 

Sample Input

1

5 1 -5 3

 

Sample Output

2

 

 

【思路】

按照物理公式去做就好,斜抛运动用动能定理去搞,得到所有落点的坐标每次判断一下。

 

【代码】

//******************************************************************************
// File Name: 1012.cpp
// Author: Shili_Xu
// E-Mail: shili_xu@qq.com
// Created Time: 2018年08月08日 星期三 13时29分18秒
//******************************************************************************

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;

const double PI = acos(-1), EPS = 1e-8, G = 9.8;

int sgn(double x)
{
	if (fabs(x) < EPS) return 0;
	return (x > 0 ? 1 : -1);
}

int t;
double x, y, a, b;

int main()
{
	scanf("%d", &t);
	while (t--) {
		scanf("%lf %lf %lf %lf", &a, &b, &x, &y);
		double phi = atan(b / a), theta = 0;
		double yp = -b / a * x;
		double v = sqrt(G * 2 * (y - yp));
		y = yp;
		int cnt = 0;
		while (true) {
			if (sgn(x) > 0) break;
			cnt++;
			double beta = PI / 2 - phi * 2 - theta;
			double vx = v * cos(beta), vy = v * sin(beta);
			double ti = 2 * (vx * b + vy * a) / G / a;
			double hx = vx * ti, hy = -vy * ti + 0.5 * G * ti * ti;
			x += hx, y -= hy;
			v = sqrt(G * 2 * hy + v * v);
			vy = sqrt(v * v - vx * vx);
			theta = atan(vx / vy);
		}
		printf("%d\n", cnt);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值