The Water Problem

Problem Description

In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,an representing the size of the water source. Given a set of queries each containing 2 integers l and r, please find out the biggest water source between al and ar.

 

Input

First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,...,an, and each integer is in {1,...,106}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.

Output

For each query, output an integer representing the size of the biggest water source.

Sample Input

3 1 100 1 1 1 5 1 2 3 4 5 5 1 2 1 3 2 4 3 4 3 5 3 1 999999 1 4 1 1 1 2 2 3 3 3

Sample Output

100 2 3 4 4 5 1 999999 999999 1

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1005;
int a[maxn];int n;
int h[maxn];

int lowbit(int x){
	return x&(-x);
}

void update(int i,int val){
	while(i<=n){
		h[i]=max(h[i],val);
		i+=-i&i;
	}
}
int find(int l,int r)
{
    int ret=a[r];
    while(1)
    {
        ret=max(ret,a[r]);
        if(l==r)break;
        for(r-=1;r-l>=lowbit(r);r-=lowbit(r))
            ret=max(ret,h[r]);
    }
    return ret;
}
int query(int x,int y){//这个查询不正确 
	int ans=a[y];
	while(y>=x){
		ans=max(a[y],ans);
		y--;
		for(;y-lowbit(y)>=x;y-=lowbit(y)){
			ans=max(h[x],ans);
		}
	}
	return ans;
}
int main(){
	int T;cin>>T;
	while(T--){
		cin>>n;
		memset(a,0,sizeof(a));
		memset(h,0,sizeof(h));
		for(int i=1;i<=n;i++){
			cin>>a[i];
			update(i,a[i]);
		}
		int q;cin>>q;
		int l,r;
		while(q--){
			cin>>l>>r;
			cout<<find(l,r)<<endl;
		}
	}
	
	
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值