Parentheses Balance

Parentheses Balance


题目描述

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a) if it is the empty string

(b) if A and B are correct, AB is correct,

(c) if A is correct, (A) and [A] is correct.

(d)if there are other characters,just ignore it . for example :alksdjfajfaslkf(lskdfjldkjfslkfsdlk)slkdfjlksd is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128. 

输入

The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string a line.

输出

A sequence of ‘Yes’ or ‘No’ on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

 

Sample Output 

Yes
No
Yes


题意:

括号匹配,栈的思想,只将左括号进栈,如果是左括号,则进栈,如是右括号,则一定与栈顶匹配,若不匹配就是错误的,且最后栈一定为空才行

#include<stdio.h>
#include<string.h>

int main(){
	int n,i,j=0;
	char a[200],S[200];
	scanf("%d",&n);
	getchar();//回车 
	while(n-->0){
		j=0;
		int flag=0;
		gets(a);//输入字符串 
		if(strlen(a)==0){//字符串为空 
			printf("Yes\n");
			continue;
		}
		for(i=0;a[i]!='\0';i++){
			if((a[i]=='(')||(a[i]=='[')){
				S[j++]=a[i];//相当于进栈 
			}
			else if((a[i]==')')||(a[i]==']')){
				if((a[i]==')'&&S[j-1]==a[i]-1)||(a[i]==']'&&S[j-1]==a[i]-2)) j--;//j--相当于出栈 
				else{ 
					flag=1;
					break;
				}
			}
		}
		if(j==0&&flag==0) printf("Yes\n");//栈空且都配对成功 
		else printf("No\n");
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值