Parentheses Balance (栈)

Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description

(a)You are given a string consisting of parentheses () and []. A string of this type is said to becorrect:

if it is the empty string

(b)

if A and B are correct, AB is correct,

(c)

if A is correct, (A ) and [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.

Output 

A sequence of Yes or No on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes

  一开始想的太简单了,就数了一下()[]的数目看是否相等,结果wro了,突然明白  )))((( 这种情况也不行,菜鸡啊!

思路: 还是栈,注意([)]这种情况是不行的

写就写呗,交了好几次,又wro了,草,for循环的i忘赋初值0了

   代码:

不能用scanf,要用gets,因为scanf'不能接收\n,但gets可以

#include<iostream>
#include<stack>
#include<cstring>
using namespace std;
int main()
{
	int n;
	char s[150];
	cin>>n;
	getchar();
	while(n--)
	{
	    gets(s);
		stack<char> st;
		while(!st.empty()) st.pop();
		
		int len=strlen(s);
		for(int i=0;i<len;i++)
		{
			if(s[i]=='('||s[i]=='[') st.push(s[i]);
			else
			{
				if(st.size() && s[i]==')' && st.top()=='(')      st.pop();
				else if(st.size() && s[i]==']' && st.top()=='[') st.pop();
				else st.push(s[i]);
			} 
		}
		if(st.size()==0)
		  cout<<"Yes"<<endl;
		else
		  cout<<"No"<<endl;
	}
	return 0;
}
 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ksuper&

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值