POJ 1401 Factorial

Factorial
Time Limit: 1500MS Memory Limit: 65536K
Total Submissions: 16192 Accepted: 9984

Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically. 

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high even for a relatively small N. 

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function. 

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1 < N2, then Z(N1) <= Z(N2). It is because we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently. 

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861

2183837

拿到这个题目,题目要求是求N!的末尾有多少个零。开始以为是大数据运算,仔细一想便可知,只有2*5才能产生0,所以此

题是找5的倍数(25算两个5,625算四个5……)的个数与2的倍数的个数。那么问题就简单多了,直接上代码

#include <stdio.h>
#include <stdlib.h>

int min(int m,int n)
{
    return m>n?n:m;
}
int main()
{
    int T,N;
    int number2,number5;
    scanf("%d",&T);
    for(int i=0; i<T; i++)
    {
        number2=number5=0;
        scanf("%d",&N);
        number2=N/2;
        int t=5,k;
        for(int j=1; t<N; j++)
        {
            number5++;
            t=j*5;
            if(j%5==0)
            {
                k=j;
                while(k%5==0)          //记录多余的5的个数
                {
                    number5++;
                    k/=5;
                }
            }
        }
        printf("%d\n",min(number2,number5));
    }
    return 0;
}

这个代码看起来没问题,于是拿着题目的样例跑了一次。然而,运行结果如下:

6
3
0
60
14
100
24
1024
255(253)
23456
5862(5861)
8735373
2183840(2183837)

由此可见应付小数字很准确,但数据大一点就出问题了(还好没提交),嫌调试起来麻烦,索性换了一种求5的个数的方法,修

改后的代码如下

#include <stdio.h>
#include <stdlib.h>

int min(int m,int n)
{
    return m>n?n:m;
}
int main()
{
    int T,N;
    scanf("%d",&T);
    int number2,number5;
    for(int i=0; i<T; i++)
    {
        number2=number5=0;
        scanf("%d",&N);
        number2=N/2;
        while(N)
        {
            number5=number5+N/5;         //每次取5的倍数的个数
            N/=5;                        //每次除以5
        }
        printf("%d\n",min(number2,number5));
    }
    return 0;
}
测试数据正常(目测可以过=。=),拿去提交,一次AC没毛病。这些看起来是大数据运算题其实大多数都有取巧的方法搞定。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值