POJ3624背包问题

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38547 Accepted: 16723

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
    拿到这个题目,首先想到的是算出每一个元素的权(平均价值),再排序,再开循环依次判断,输出价值和。以下是我写的代码
#include <stdio.h>
#include <stdlib.h>

typedef struct about
{
    int weight;
    int vual;
    double power;
} T;
T arr[3500];
int cmp(const void*a,const void*b)
{
    T *A=(T *)a;
    T *B=(T *)b;
    return B->power-A->power>0?1:-1;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int sum=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&arr[i].weight,&arr[i].vual);
            arr[i].power=arr[i].vual*1.0/arr[i].weight;
        }
        qsort(arr,n,sizeof(about),cmp);            //将结构体按照power的从大到小排序
        for(int i=0; i<n; i++)
        {
            if(m>arr[i].weight)                  //依次判断总质量m与每个元素质量的大小
            {
                m-=arr[i].weight;
                sum+=arr[i].vual;
            }
            else
            {
                sum+=m*arr[i].power;
                break;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
    代码写的挺顺手的,结果运行起来WA,搞不清楚为什么。于是就和小组的成员一起讨论了一下,发现了问题,给出的每个物体不能拆分。开始以为这个题目就是个纯粹的贪心,纠结了一下输出的数为什么是整数而不是小数,结果问题果然出现在这里。修改后的代码如下
#include <stdio.h>
#include <string.h>

int max(int a,int b)
{
    return a>b?a:b;
}
typedef struct about
{
    int weight;
    int vual;
} T;
T arr[4000];
int main()
{
    int n,m,i,j;
    int dp[40000];
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        for(i = 0; i<n; i++)
            scanf("%d%d",&arr[i].weight,&arr[i].vual);
        for(i = 0; i<n; i++)
            for(j = m; j>=arr[i].weight; j--)
                dp[j] = max(dp[j],dp[j-arr[i].weight]+arr[i].vual);
        printf("%d\n",dp[m]);
    }
    return 0;
}
    一次AC。有时候看英文的翻译,题目的意思会被曲解,英语不能落下。


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值