HDU1789贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13918    Accepted Submission(s): 8077


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
    拿到这个题目,便知道这题是个贪心。开始的时候我是先按照限制时间排序,然后相同时间按分数的由高到低排虚,写着写着就否认掉这种方法了,原因是对于时间重复的可能同时存在几个解,而且自己得到的不一定是最优解。后来又想着按分数由高到低,分数相同时按照时间的由大到小排序,再依次判断。就是判断时间的时候有点小问题,这是我开始的时候写的代码,有问题
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;

typedef struct works
{
    int time;
    int point;
} T;
T arr[1005];
int flag[1005];
int cmp(T a,T b)
{

    if(a.point!=b.point) return a.point>b.point;
    else return a.time<b.time;
}
int main()
{
    freopen("in.txt","r",stdin);
    int n,t,sum;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d",&t);
        for(int i=0; i<t; i++)
            scanf("%d",&arr[i].time);
        for(int i=0; i<t; i++)
        {
            scanf("%d",&arr[i].point);
            sum+=arr[i].point;
        }
        sort(arr,arr+t,cmp);
        int restdays=t;
        for(int i=0; i<1005; i++) flag[i]=0;
        for(int i=0; i<t; i++)
        {
            if(restdays>=arr[i].time)
            {
                restdays--;
                sum-=arr[i].point;
            }
            else continue;
        }
        printf("%d\n",sum);
    }
    return 0;
}
    经过调试就发现是最后一段关于时间取舍的问题,尤其是第一组数据,时间全是三天的时候,减完第一组数据,restdays就变成2了,然后就出错。后来构思了一下,设计了以下的处理方法。
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;

typedef struct works
{
    int time;
    int point;
} T;
T arr[1005];
int flag[1005];
int cmp(T a,T b)
{

    if(a.point!=b.point) return a.point>b.point;
    else return a.time<b.time;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int n,t,sum;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d",&t);
        for(int i=0; i<t; i++)
            scanf("%d",&arr[i].time);
        for(int i=0; i<t; i++)
            scanf("%d",&arr[i].point);
        sort(arr,arr+t,cmp);
        for(int i=0; i<1005; i++) flag[i]=0;
        for (int i=0,j; i<t; i++)
        {
            for (j=arr[i].time; j>0; j--)
            {
                if(!flag[j])
                {
                    flag[j] = 1;
                    break;
                }
            }
            if(j == 0)
                sum += arr[i].point;
        }
        printf("%d\n",sum);
    }
    return 0;
}
     一次AC。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值