POJ3278BFS

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 94506 Accepted: 29650

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

        题意:一维数轴上有两个点,要求求从一个点到另一个点的最小步数,在X可以走到X+1或X-1或2*X。

        解题思路:这个题是个很水的BFS题,基本套模板。以下是我的AC代码

#include <iostream>
#include <queue>
#include <cstdio>
#include <memory.h>
using namespace std;
#define maxn 100005

bool flag[maxn];
struct trip
{
    int x,step;
};
int n,k;
int check(int x)
{
    if(x<0||x>=maxn) return 1;
    return flag[x];
}
void bfs()
{
    queue<trip> q;
    trip now,next;
    now.x=n;
    now.step=0;
    flag[now.x]=true;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.x==k)
        {
            printf("%d\n",now.step);
            break;
        }
        for(int i=0;i<3;i++)
        {
            if(i==0) next.x=now.x+1;
            else if(i==1) next.x=now.x-1;
            else if(i==2) next.x=now.x*2;
            if(check(next.x)) continue;
            next.step=now.step+1;
            flag[next.x]=true;
            q.push(next);
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d%d",&n,&k);
    memset(flag,false,sizeof(flag));
    bfs();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值