POJ 2796 Feel Good(单调栈+线段树)

Feel Good(单调栈+线段树)

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 17746Accepted: 4900
Case Time Limit: 1000MSSpecial Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.
A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.
Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.
Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill’s life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, … an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill’s life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

题意

  给出一个长度为n的序列,找出一个区间要求该区间数的和*该区间最小值的值最大,输出这个值和区间左右边界,如果有多组解,任意输出一种即可。

解题思路

  这题感觉跟HDU 1506有些相似,其核心思想就是对于每个最优区间,假设边界相邻的元素比区间最小值大,那么相邻元素必须被合并进去,但是这个最优区间就改变了,这与假设相悖,则边界的临界条件就是出现第一个比区间最小值小的数。对于每个元素,需要找到每从左(从右)第一个比它小的数,最后再递推出最大值就行了,涉及到区间求和我用的线段树。注意数据范围,会爆int。

/*
                   _ooOoo_
                  o8888888o
                  88" . "88
                  (| -_- |)
                  O\  =  /O
               ____/`---'\____
             .'  \\|     |//  `.
            /  \\|||  :  |||//  \
           /  _||||| -:- |||||-  \
           |   | \\\  -  /// |   |
           | \_|  ''\---/''  |   |
           \  .-\__  `-`  ___/-. /
         ___`. .'  /--.--\  `. . __
      ."" '<  `.___\_<|>_/___.'  >'"".
     | | :  `- \`.;`\ _ /`;.`/ - ` : | |
     \  \ `-.   \_ __\ /__ _/   .-` /  /
======`-.____`-.___\_____/___.-`____.-'======
                   `=---='
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
            佛祖保佑       永无BUG
*/
#include<stdio.h>
#include<stack>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e5+50;

long long tree[maxn<<2],arr[maxn];
int l[maxn],r[maxn];
stack<int> s;

void pushup(int rt)
{
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        tree[rt]=arr[l];
        return;
    }
    int m=l+r>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
long long query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R) return tree[rt];
    int m=l+r>>1;
    long long ans=0;
    if(L<=m) ans+=query(L,R,l,m,rt<<1);
    if(R> m) ans+=query(L,R,m+1,r,rt<<1|1);
    return ans;
}
int main()
{
#ifdef DEBUG
    freopen("in.txt","r",stdin);
#endif // DEBUG
    int n;
    scanf("%d",&n);
    for(int i=1; i<=n; i++) scanf("%d",&arr[i]);
    build(1,n,1);
    while(s.size()) s.pop();
    for(int i=1; i<=n; i++)
    {
        while(s.size()&&arr[s.top()]>=arr[i]) s.pop();
        if(s.empty()) l[i]=1;
        else l[i]=s.top()+1;
        s.push(i);
    }
    while(s.size()) s.pop();
    for(int i=n; i>=1; i--)
    {
        while(s.size()&&arr[s.top()]>=arr[i]) s.pop();
        if(s.empty()) r[i]=n;
        else r[i]=s.top()-1;
        s.push(i);
    }
    long long ans=-0x3f3f3f3f;
    int pos=0;
    for(int i=1; i<=n; i++)
    {
        long long t=query(l[i],r[i],1,n,1)*arr[i];
        if(ans<t)
        {
            ans=t;
            pos=i;
        }
    }
    printf("%lld\n%d %d\n",ans,l[pos],r[pos]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值