Knight Moves POJ - 1915 (bfs)

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input
The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output
5
28
0
题目大意:给定一个起点和一个终点,问以国际象棋中骑士的走法最少需要多少步从起点到终点。
解题思路:bfs水题每次暴力走8个方向谁先到达最后个点则为最少步数此题不用考虑找不到的情况;
ac代码:

#include <iostream>
#include <cstring>
#include <set>
#include<memory>
#include<stdio.h>
#include<queue>
using namespace std;
bool map[305][305];int dist[305][305];
int sx,sy,ex,ey,n;
int a[8][2]= {1,2,1,-2,-1,2,-1,-2,2,1,2,-1,-2,1,-2,-1};
struct state
{
    int xx;
    int yy;
}pp,p;
void bfs ()
{
    queue<state> q;
    memset(map,0,sizeof(map));
    memset(dist,0,sizeof(dist));
    pp.xx=sx;
    pp.yy=sy;
    q.push(pp);
    while(!q.empty())
    {
        int x,y;
        x=q.front().xx;
        y=q.front().yy;
        q.pop();
        if(x==ex&&y==ey)break;
        map[x][y]=1;
        int tx,ty;
        for(int i=0;i<8;i++)
        {
            tx=x+a[i][0];
            ty=y+a[i][1];
            if(tx>=0&&ty>=0&&ty<n&&tx<n&&!map[tx][ty])
            {
                dist[tx][ty]=dist[x][y]+1;
                p.xx=tx;
                p.yy=ty;
                q.push(p);
                map[tx][ty]=true;
            }
        }
    }
}
int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
       scanf("%d",&n);
       scanf("%d%d",&sx,&sy);
       scanf("%d%d",&ex,&ey);
       bfs();
       printf("%d\n",dist[ex][ey]);
   }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值