POJ 2001 Shortest Prefixes 字典树经典题,求最短唯一前缀)

Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 18950 Accepted: 8209

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
 
 
题意
  给你若干个单词的字典,求字典中每一个单词的最短唯一前缀。
  最短唯一前缀:找出这个单词中的一个前缀,要求这个前缀只在这个单词中出现过,并且要求这个前缀最短。
思路
  实际上就是找字典树中 前缀数域 为1的位置,输出到这个位置为止的字符串。
  字典树这样定义,26个指向下一个位置的指针,1个num域,这个num代表以当前字符串为前缀的单词的数量。
  这样只要找到num==1的位置即可(到这个位置只有一个单词通过,说明到当前位置为止的字符串是唯一的)。
#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
using namespace std;
struct Tire
{
	int num; //存储以当前字符串为前缀的字符串的数量
	Tire *next[26];
	Tire()
	{
		num=0;
		memset(next,0,sizeof(next));
	}
}root;
char s[1005][25];
int n=0;
void insert(char *s)
{
	Tire *p=&root;
	for(int i=0;s[i];i++)
	{
		int index=s[i]-'a';
		if(!p->next[index])
			p->next[index]=new Tire;
		p=p->next[index];
		p->num++; 
	}
}

void find(char *s)
{
	Tire *p=&root;
	int i;
	char str[25]={0}; //记录最短唯一前缀
	for(i=0;s[i];i++)
	{
		int index=s[i]-'a';
		if(p->num==1) break; //num为1说明这个前缀只在这个单词中出现过,即符合要求的 
		str[i]=s[i];
		p=p->next[index];
	}
	cout<<str<<endl;
}

int main()
{
//	freopen("E:\\ACM\\test.txt","r",stdin);
	char str[25];
	while(cin>>s[n])
	{	
		insert(s[n++]);
	}
	for(int i=0;i<n;i++)
	{
		cout<<s[i]<<" "; 
		find(s[i]);	
	}
	return 0;
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值