PAT甲级1006

1006. Sign In and Sign Out (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.


Input Specification:


Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:


ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.


Output Specification:


For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.


Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.


Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:

SC3021234 CS301133

以上是题目

以下是代码

#include <iostream>
#include <vector>
#include <string>

using namespace std;

class sign_inf{
public:
     string ID_number;
string Sign_in_time;
string Sign_out_time;
      sign_inf(string IDNumber,string SignIn,string SignOut);
};

sign_inf::sign_inf(string IDNumber = "",string SignIn = "",string SignOut = ""){
    ID_number = IDNumber;
    Sign_in_time = SignIn;
    Sign_out_time = SignOut;
}

int main(){
    sign_inf example;
    vector<sign_inf> seq;
     int number;
    cin >> number;
     for( int i= 0;i<number;i++){
        cin >> example. ID_number >> example. Sign_in_time >> example. Sign_out_time;
        seq. push_back(example);
    }
    string max_id = seq. begin()-> ID_number;
    string min_id = seq. begin()-> ID_number;
    string max_time = seq. begin()-> Sign_out_time;
    string min_time = seq. begin()-> Sign_in_time;
     for(vector<sign_inf>::iterator i=seq. begin()+ 1;i<seq. end();i++){
         if(i-> Sign_in_time < min_time){
            min_time = i-> Sign_in_time;
            min_id = i-> ID_number;
        }
         if(i-> Sign_out_time > max_time){
            max_time = i-> Sign_out_time;
            max_id = i-> ID_number;
        }
    }
    cout << min_id << " " << max_id << endl;
}
总结:很简单的题目,我的思路就是通过c++ 的string类来比较找到最小字符串和最大字符串,直接得到结果,当然也可以通过scanf("%s %d:%d:%d %d:%d:%d" &a,&b,&c,&d,&e,&f,&g)的形式得到各个时钟位值然后统一换算成秒计算比较得到最大最小值,也十分方便。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值