PAT甲级1014

1014. Waiting in Line (30)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:


The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.


For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.


At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.


Input


Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).


The next line contains K positive integers, which are the processing time of the K customers.


The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.


Output


For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.


Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

 

以上是题目,以下是解答

#include<stdio.h>
#include<queue>
#include<stdlib.h>

using namespace std;

struct custmor{
    int start_time;
    int finish_time;
    int during_time;
};
int end_time[21] = {0};
custmor custom[1001];
queue<custmor>window[21];
int main(){
    int n,m,k,q;
    int cnt = 1;
    scanf("%d%d%d%d",&n,&m,&k,&q);
    for(int i = 1; i <= k; i++){
        scanf("%d",&(custom[i].during_time));
    }
    for(int i = 1; i<= m; i++){
        for(int j = 1; j <=n && cnt <= k; j++){
            custom[cnt].start_time = end_time[j];
            custom[cnt].finish_time = end_time[j] + custom[cnt].during_time;
            end_time[j] = custom[cnt].finish_time;
            window[j].push(custom[cnt]);
            cnt++;
        }
    }
    int min_time,min_window;
    while(cnt <= k){
        min_time = window[1].front().finish_time;
        min_window = 1;
        for(int i = 1; i <= n; i++){
            if(window[i].front().finish_time < min_time){
                min_time = window[i].front().finish_time;
                min_window = i;
            }
        }
        window[min_window].pop();
        custom[cnt].start_time = end_time[min_window];
        custom[cnt].finish_time = end_time[min_window] + custom[cnt].during_time;
        end_time[min_window] = custom[cnt].finish_time;
        window[min_window].push(custom[cnt]);
        cnt++;
    }
    int custm;
    for(int i =0; i < q; i++){
        scanf("%d",&custm);
        if(custom[custm].start_time >= 540)
            printf("Sorry\n");
        else
            printf("%02d:%02d\n",(custom[custm].finish_time+480)/60,(custom[custm].finish_time%60));
    }
    system("pause");
    return 0;
}

 

小结:嗯,该题没有考到数据结构的相关知识,是对实际情况的模拟,考的是个人的逻辑能力,相对来说不是非常难,可以通过建立几个队列模拟窗口来解决问题。然后这里有一个非常坑的陷阱要注意,原文中的“ for those customers who cannot be served before 17:00, you must output "Sorry" instead.”指的是在>=17:00排队的人输出Sorry,因为这坑爹的理解错误,我一下午的休息时光没了orz.....

2019.2.3二刷:emm,开始看题目已经完全不会了.....最后又遇到了上面说的问题,题目还是得好好看....还有是早八晚五想当然的算成了8个小时orz,难受...

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值