小白算法练习 单调栈 POJ 2796

Feel Good

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 17691 Accepted: 4883
Case Time Limit: 1000MS Special Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5
#include<iostream>
#include<cstring>
#include<cstdio>
#include<stack>
using namespace std;
const int maxm=111111;
int R[maxm],L[maxm],C[maxm],n;
long long sum[maxm];
struct Node{
	int id;
	int x;
};
//stack<Node>sta;
inline void dostack(Node node[maxm]){
	stack<Node>sta;
	for(int i=1;i<=n;i++)
	{
		while(!sta.empty() && sta.top().x>node[i].x)
		{
			R[sta.top().id]=i-sta.top().id-1;
			sta.pop();
		}
		sta.push(node[i]);
	}
	while(!sta.empty())
	{
		R[sta.top().id]=n-sta.top().id;
		sta.pop();
	}
} 
inline void dorstack(Node node[maxm]){
	stack<Node>sta;
	for(int i=n;i>=1;i--)
	{
		while(!sta.empty() && sta.top().x>node[i].x)
		{
			L[sta.top().id]=sta.top().id-i-1;
			sta.pop();
		}
		sta.push(node[i]);
	}
	while(!sta.empty())
	{
		L[sta.top().id]=sta.top().id-1;
		sta.pop();
	}
} 
int main()
{
while(scanf("%d",&n)!=EOF){
	Node node[maxm];
	memset(R,0,sizeof(R));
	memset(L,0,sizeof(L));
	memset(sum,0,sizeof(sum));
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&node[i].x);
		node[i].id=i;
		sum[i]=sum[i-1]+node[i].x;
	}
	dostack(node);
	dorstack(node);
	long long mx=-1;
	int mxi=0;
	for(int i=1;i<=n;i++)
	{
		if((long long)(sum[i+R[i]]-sum[i-L[i]-1])*(long long)node[i].x>=mx){
			mx=(long long)(sum[i+R[i]]-sum[i-L[i]-1])*(long long)node[i].x;
			mxi=i;
		} 
	}
	printf("%lld\n",mx);
	printf("%d %d\n",mxi-L[mxi],mxi+R[mxi]);
}
	return 0; 
} 

前后单调栈扫一遍,再用前缀和,G++过了,C++TLE;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值