CodeForces 584B

D -D
Crawling in process... Crawling failed
Time Limit: 1000MS     Memory Limit: 262144KB     64bit IO Format: %I64d & %I64u

Kolya loves putting gnomes at the circle table and giving them coins, and Tanya loves studying triplets of gnomes, sitting in the vertexes of an equilateral triangle.

More formally, there are 3n gnomes sitting in a circle. Each gnome can have from1 to3 coins. Let's number the places in the order they occur in the circle by numbers from0 to3n - 1, let the gnome sitting on thei-th place haveai coins. If there is an integeri (0 ≤ i < n) such thatai + ai + n + ai + 2n ≠ 6, then Tanya is satisfied.

Count the number of ways to choose ai so that Tanya is satisfied. As there can be many ways of distributing coins, print the remainder of this number modulo109 + 7. Two ways, a and b, are considered distinct if there is indexi (0 ≤ i < 3n), such thatai ≠ bi (that is, some gnome got different number of coins in these two ways).

Input

A single line contains number n (1 ≤ n ≤ 105) — the number of the gnomes divided by three.

Output

Print a single number — the remainder of the number of variants of distributing coins that satisfy Tanya modulo109 + 7.

Sample Input

Input
1
Output
20
Input
2
Output
680

Sample Output

Hint

20 ways for n = 1 (gnome with index0 sits on the top of the triangle, gnome1 on the right vertex, gnome 2 on the left vertex):

思路:这道题感觉不难啊,想了好久(蒟蒻的智商羁绊),看代码的递推公式吧;

#include<cstdio>
#include<cstring>
#define t 1000000007
#define ll long long
ll sdp(ll a,ll b,ll c)
{
	ll ans=1;
	while(b)
	{
		if(b&1)
			ans=ans*a%c;
		a=a*a%c;
		b>>=1;
	}
	return ans;
}
int main()
{
	ll m,n,to,tot;
	while(scanf("%lld",&n)!=EOF)
	{
		m=n*3;
		to=sdp(3,m,t);
		tot=sdp(7,n,t);
		if(to>=tot)
			printf("%lld\n",to-tot);
		else printf("%lld\n",to-tot+t);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值