Permutations
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 3205 | Accepted: 1744 |
Description
We remind that the permutation of some final set is a one-to-one mapping of the set onto itself. Less formally, that is a way to reorder elements of the set. For example, one can define a permutation of the set {1,2,3,4,5} as follows:
This record defines a permutation P as follows: P(1) = 4, P(2) = 1, P(3) = 5, etc.
What is the value of the expression P(P(1))? It’s clear, that P(P(1)) = P(4) = 2. And P(P(3)) = P(5) = 3. One can easily see that if P(n) is a permutation then P(P(n)) is a permutation as well. In our example (believe us)
It is natural to denote this permutation by P2(n) = P(P(n)). In a general form the defenition is as follows: P(n) = P1(n), Pk(n) = P(Pk-1(n)). Among the permutations there is a very important one — that moves nothing:
It is clear that for every k the following relation is satisfied: (EN)k = EN. The following less trivial statement is correct (we won't prove it here, you may prove it yourself incidentally): Let P(n) be some permutation of an N elements set. Then there exists a natural number k, that Pk = EN. The least natural k such that Pk = EN is called an order of the permutation P.
The problem that your program should solve is formulated now in a very simple manner: "Given a permutation find its order."
This record defines a permutation P as follows: P(1) = 4, P(2) = 1, P(3) = 5, etc.
What is the value of the expression P(P(1))? It’s clear, that P(P(1)) = P(4) = 2. And P(P(3)) = P(5) = 3. One can easily see that if P(n) is a permutation then P(P(n)) is a permutation as well. In our example (believe us)
It is natural to denote this permutation by P2(n) = P(P(n)). In a general form the defenition is as follows: P(n) = P1(n), Pk(n) = P(Pk-1(n)). Among the permutations there is a very important one — that moves nothing:
It is clear that for every k the following relation is satisfied: (EN)k = EN. The following less trivial statement is correct (we won't prove it here, you may prove it yourself incidentally): Let P(n) be some permutation of an N elements set. Then there exists a natural number k, that Pk = EN. The least natural k such that Pk = EN is called an order of the permutation P.
The problem that your program should solve is formulated now in a very simple manner: "Given a permutation find its order."
Input
In the first line of the standard input an only natural number N (1 <= N <= 1000) is contained, that is a number of elements in the set that is rearranged by this permutation. In the second line there are N natural numbers of the range from 1 up to N, separated by a space, that define a permutation — the numbers P(1), P(2),…, P(N).
Output
You should write an only natural number to the standard output, that is an order of the permutation. You may consider that an answer shouldn't exceed 10
9.
Sample Input
5 4 1 5 2 3
Sample Output
6
题意:按照题意图示的变换(不是求最少步数,不要曲解),求出变换的步数;
思路:按照题意在纸上模拟一遍:(加输出有助于理解,好习惯)
4 1 5 2 3 :初始序列
1 2 3 4 5 :目标序列
3 3 2 3 2 :循环节(顾名思义,就是经过多少次变换能够回到原来的位置,这里表达的就是每个位置的循环节);
(1 2 4)循环节为3,(3 5)循环节为2,先只需求这些个循环节的秩(也就是lcm),lcm值就是anwer;
#include<cstdio>
#include<cstring>
#define max_n 1010
int num[max_n];
int gcd(int a,int b)
{
return b?gcd(b,a%b):a;
}
int lcm(int a,int b)
{
return a/gcd(a,b)*b;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int ans=1;
for(int i=1;i<=n;i++)
scanf("%d",&num[i]);
for(int i=1;i<=n;i++)
{
int t=num[i],res=1;
while(t!=i)
{
// printf("%d -> %d -> %d\n",i,t,num[t]);
t=num[t];
res++;
}
// printf("%d -> %d -> %d\n\n",i,t,num[t]);
ans=lcm(ans,res);
}
printf("%d\n",ans);
}
return 0;
}