UVA - 10815【字符串处理STL】

题目链接

Andy, 8, has a dream - he wants to produce his
very own dictionary. This is not an easy task for
him, as the number of words that he knows is,
well, not quite enough. Instead of thinking up all
the words himself, he has a briliant idea. From
his bookshelf he would pick one of his favourite
story books, from which he would copy out all
the distinct words. By arranging the words in
alphabetical order, he is done! Of course, it is
a really time-consuming job, and this is where a
computer program is helpful.
You are asked to write a program that lists
all the different words in the input text. In this
problem, a word is defined as a consecutive sequence
of alphabets, in upper and/or lower case.
Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE.
For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input
is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The
words should all be in lower case, sorted in alphabetical order. You can be sure that he number of
distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: “Disneyland Left.”
So they went home.
Sample Output
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
题意:
输入一段英语文章,把单词提取出来并按照字典序排序,排序后的字母不能重复;
思路:
先输入,分成单个字符,处理后的单个单词处理并存储到二维数组里,用STL排序(好好看看),最后判断相邻是否相等,就可以去重了,注意数组开的大小;

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
#include<map>
#include<string>
#include<vector>
#define max_n 5010
using namespace std;
char str[max_n*1000],ch[max_n*1000],a[max_n*10][110];

vector<string> words;

int main()
{
    int j=0;
    while(gets(str))
    {
        int p=0;
        int len=strlen(str);
        if(len==0) continue;
        str[len]=' ';
        for(int i=0;i<=len;i++) //处理字符串 
        {
            if(str[i]>='A' && str[i]<='Z')//有大小写
                ch[p++]=str[i]-'A'+'a';
            else if(str[i]>='a' && str[i]<='z')
                ch[p++]=str[i];
            else
            {
                ch[p]='\0';
                if(p!=0)
                    strcpy(a[j++],ch);
                p=0;
            }
        }
    }
    for(int i=0;i<j;i++)
        words.push_back(a[i]);
    sort(words.begin(),words.end()); //排序 
    cout<<words[0]<<"\n";
    for(int i=1;i<words.size();i++)
    {
        if(words[i]!=words[i-1]) //去重 
                cout<<words[i]<<"\n";
    }
    return 0;
} 
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值