UVA 10815——set用法(一)

这道例题涉及了set中几个函数的用法以及用迭代器遍历、用函数转换大小写等,很方便,还是很值得学习的……

题意比较简单,就是输入文本,找出所有不同的单词(只出现一次),然后按字典序从小到大输出就好。

题目:

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful. You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the road. The sign read: "Disneyland Left."
So they went home.

Sample Output
a

adventures

blondes

came

disneyland

fork

going

home

in

left

read

road

sign

so

the

they

to

two

went

were

when

下面是代码:

#include<iostream>
#include<set>
#include<sstream>
#include<string>
using namespace std;
set<string>se;//定义一个string类型的set容器
int main(void)
{
	int i;
	string s1,s2;
	while(cin>>s1)
	{
		for(i=0;i<s1.length();i++)
		{
			if(isalpha(s1[i]))
			   s1[i]=tolower(s1[i]);
			else
			   s1[i]=' ';
		}
		stringstream str(s1);
		while(str>>s2)
		   se.insert(s2);//因为set中元素不会重复,所以重复的元素只会被插入一个
	}
	for(set<string>::iterator it=se.begin();it!=se.end();++it)//用迭代器遍历数据,在set中元素已经排好
	  cout<<*it<<"\n";
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值