POJ - 3107 Godfather【树形dp+树的重心】

Godfather

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7728 Accepted: 2741

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There aren persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangsterbi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3

题意:给你一颗树,输出所有树的重心;

思路:有点小成就,学了一下树形dp,自己用树形dp搭造的状态方程:

dp【i】【0】:表示以i节点为根节点,所有子树中最多的节点数;

dp【i】【1】:表示以i节点为根节点,向上查询的最多的节点数;

dp【i】【2】:表示以i节点为根节点,所有子节点和;

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <queue>
using namespace std;

const int MAXN = 5 * 1e4 + 5;
int dp[MAXN][5], head[MAXN];
int n, p1, p2, cnt = 0;

struct node {
	int to;
	int next;
}edge[MAXN << 1];

void add_edge(int u, int v) {
	edge[cnt].to = v;
	edge[cnt].next = head[u];
	head[u] = cnt++;
}

void dfs(int x, int fa) {
	int res = 0;
	for(int i = head[x]; i != -1; i = edge[i].next) {
		int u = edge[i].to;
		if(u == fa) continue;
		dfs(u, x);
		res = res + dp[u][2] + 1;
		dp[x][0] = max(dp[u][2] + 1, dp[x][0]);
	}
	dp[x][1] = n - res - 1;
	dp[x][2] = res;
}

int main() {
	memset(head, -1, sizeof(head));
	scanf("%d", &n);
	for(int i = 1; i < n; i++) {
		scanf("%d %d", &p1, &p2);
		add_edge(p1, p2);
		add_edge(p2, p1);
	} 
	dfs(1, -1);
	int ans = 0x3f3f3f3f;
	for(int i = 1; i <= n; i++) {
	//	printf("%d -> %d -> %d\n", i, dp[i][0], dp[i][1]);
		if(max(dp[i][0], dp[i][1]) < ans) {
			ans = max(dp[i][0], dp[i][1]);
		}
	}
	bool flag = false;
	for(int i = 1; i <= n; i++) {
		if(max(dp[i][0], dp[i][1]) == ans) {
			if(flag) printf(" ");
			printf("%d", i);
			flag = true;
		}
	}
	printf("\n");
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值